User Avatar Image

ToMI - WASD on a non-QWERTY keyboard

posted by kino on - last edited - Viewed by 296 users

Hey, is there a way I can customize the control keys ingame? I am using a french keyboard (AZERTY), and the game forces me to use WASD instead of actually ZQSD.

I'm used to this behavior in Flash freewares and some FPS, but the latter always have customizable controls, and the former, well they're just dumb Flash games.

Using the mouse to walk around is nearly impossible. I'm really sorry you guys went this route for the controls, when good old point and click would just have worked better.

I'm not here to rant though. Anyone can think of a fix (other than set my OS to English) so I can enjoy the game beyond the demo? Thanks :)

4 Comments - Linear Discussion: Classic Style
  • two ways I see around this:

    1) use the arrow keys instead of WASD

    2) I don't know what operating system you are using but in XP at least you can go into the control panel, open the 'regional & language options'. then click on the Languages tab (2nd one for me) then press details in the 'Text services & input languages'. In this new window I can press Add to bring me another screen where you can select an input language from a drop down list. I was able to chose French and ok it. Then at the top of the previous screen I can change the default language from English to French and once I've pressed ok my keyboard acts like a French one.

    I know that 2nd option sounds a bit complicated and it may not even work for you!

  • I don't know exactly how, but I know it's possible to enable a "language bar" in the task bar that allows to quickly change the keyboard locale settings. IIRC (I'm on a Mac right now, no PC at hand), it is application specific, so it won't affect other apps running. I don't think it remembers the settings from one run to the next, though.

  • Thanks. I know about the language bar, but I was hoping for something on the game's side that I don't have to switch every time I run it.

    EDIT: Thanks for the arrow keys advice, corruptbiggins. The controls are still less than ideal, but it's the most playable so far.

    I think I may just wait for the WiiWare version if the controls turn out better in that. Hopefully that does hit Europe in the not too distant future.

  • See, I just played Trine, and the game work around the AZERTY WASD issue just fine.

    Please Telltale, take this into account for future episodes/games. Surely you don't have to go through the OS to tell you which key is being hit. It's just impractical for international users. If this was a Flash game I would understand the 'sandboxy" limitations, but DirectX?

    EDIT: For international gamers experiencing the same problem, the definitive (for now) solution seems to be the following:

    - Add English (United States) to your language bar (should be enabled by default after a fresh install).
    - Start the game.
    - While in the game, press Alt+Shift to switch to English. I've tested and WASD should now work correctly.

Add Comment