User Avatar Image

TOMI works fine on Linux using VMWare

posted by dflock on - Viewed by 136 users

Hi,
Just thought I'd let people know that TOMI is working fine for me on Linux, running in a VMWare virtual machine. I tried it under both Wine (1.1.25) and VirtualBox (3.0.0) and couldn't get it to work, but it works fine using VMWare.

This is my setup, in case it helps anyone:

Ubuntu Jaunty (9.04), AMD64 (64bit), Intel Core 2Quad, 8Gb RAM, NVidia 8800GTS (600Mb vRam).
VMWare Workstation (6.5.2), with a Windows XP virtual Machine, with a 10GB virtual disk and 1Gb RAM assigned. Tick the 'Accelerate 3D Grapihcs (Directx 9.0c)' checkbox in the VM hardware/graphics settings. Install VMWare extensions into the VM.
Install TOMI, let it do whatever DirectX stuff it wants during setup. Make the desktop icon, but don't start the game yet. Run 'dxdiag' and make sure all the Direct3D/DirectX tests run smoothly and pass. The spinning cube is almost too fast to see on my setup; ideally it should be fast and smooth. Make sure the sound tests pass too.
Try the game, hopefully it works. I'm running VMWare windowed but TOMI fullscreen in the VM. I'm running TOMI at quality level 6 and the resolution is about 1280x800 (can't remember exactly). You'll probably need to adjust graphics quality and resolution until your hardware can cope; I originally started a bit higher than this and it crashed quite a bit - now it's completely stable.

Hope this helps someone!
Dunc

0 Comments - Linear Discussion: Classic Style
Add Comment