User Avatar Image

TMI graphics glitch?

posted by CuriosTiger on - last edited - Viewed by 117 users

I installed TMI on a second computer; actually a Virtual Machine running Windows Vista (host OS Mac OS X). After dropping the graphics level down to 6, the game plays acceptably. However, there was a weird graphics glitch during the cut scene between the intro (on the boats) and when Guybrush washes up on Flotsam Island. I've attached a screen shot; any idea what would cause this?

I did let TMI install all the DirectX drivers it wanted to.

4 Comments - Linear Discussion: Classic Style
  • That's... very strange. I know what the problem is, I just don't know why it's happening. You know the little piece of paper that flies through the air with the game logo on it? Well that's like a giant tail that it's leaving through the sky. In earlier builds of the game, we essentially had that same issue because of the way the texture was built, but we fixed it a few weeks before launch.

    The thing is, I can't think of any reason that would be happening on your game. It's *possible* that that one texture got corrupted in just the right way. It could also potentially be something video card/DX related, but I'm not sure what or how.

    Does your video card have any sort of special feature that compresses textures? I know a few of them do, and that could potentially cause it.

  • I think you're essentially dealing with WINE here. He doesn't say which virtual machine he's using but seeing as most that offer Direct3D support do so by implementing WINE's D3D->OGL layer it seems very likely. May be interesting to check which WINE version the VM is based on.

  • It's not WINE, it's the latest beta version of VMware Fusion for the Mac.

    Granted, as a beta, this could have something to do with VMware's new DirectX driver (which enables Aero). Is there anything I can run to help supply information?

  • What I meant was, it may use the WINE D3D->OGL Layer, like Parallels does.

Add Comment