User Avatar Image

Problems with ToMI 3 - [issue-21670]

posted by clairelc on - last edited - Viewed by 115 users

Hi there,

first post, unfortunately because i can't ToMI 3 to work! I've sent an email to support, and getting some advice ([issue-21670]) but nothing working, so thought I'd see what people here had to say...

Basically when i try to install ToMI 3, if i select the option to check/update direct x, the installer just hangs. If i select the option to not check direct x, the installer completes sucessfully, but when it tries to launch the game i get an "internal error" dialogue box.

ToMI 1 & 2 both still work.

I have tried re-downloading the installer from the site several times, and through different browsers. I have also manually updated direct x.

I can't recall installing anything new on my laptop since the last ToMI release (with the exception of windows updates - any known compatability issues there?).

If anyone has any ideas what could be causing the problem, then please let me know...

thanks

4 Comments - Linear Discussion: Classic Style
  • Hi, I'm having the same trouble too, with MI I and II working, but not this latest one. The program crashes and a dialogue box pops up to ask if I want to close the program, close and have Windows find a solution online, or debug the program. Running this under Vista.

  • Hmm, could you try updating DirectX directly from Msoft? That would definitely get you up to date. http://www.microsoft.com/downloads/details.aspx?FamilyID=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en

  • I've already done that and still no joy :-(

  • User Avatar Image
    DjNDB Moderator

    Does it still happen if you start the game after a clean boot like this?

    Pick the one for your Windows Version.

    Msconfig for Windows XP:
    To Boot Clean in Windows XP

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Process SYSTEM.INI file
    4. Uncheck Process WIN.INI file
    5. Uncheck Load Startup Items
    6. Click on the Services tab
    7. At the bottom, check Hide All Microsoft Services
    8. Uncheck all boxes in the window or click the button labeled Disable All
    6. Click OK
    7. Click Restart
    8. After reboot, run the game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click OK
    4. Click YES, when asked to restart your computer

    Based on Will's post





    Msconfig for Windows Vista:
    To Boot Clean in Windows Vista

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Load Startup Items
    4. Select the Services tab
    5. Check Hide all Microsoft services
    6. Click Disable all
    7. Click on OK
    8. Click Restart.
    9. After reboot, run game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click Ok
    4. Click Yes, when asked to restart your computer

    Based on Will's post

Add Comment