User Avatar Image

Sam and Max fails to display in portrait mode

posted by Sar on - last edited - Viewed by 529 users

I habitually run a two-monitor setup with my main monitor in portrait; it's driven from a GeForce 6600 GT set to 'Rotate 90 degrees' in NVRotate, 1024x1280px, 32bpp colour.

If I start the Sam and Max demo with the monitor in this mode, then it first displays blank black (when it would be showing logos) then blank white with the credits music rolling... but nothing but white displayed.

If I change to unrotated, it displays fine.

I know "I would buy your product if..." posts are a little weak, but seriously - I enjoyed the demo enough to pay $9 for the episode, but not enough to rotate my monitor both in settings and also physically before and after each time I play it. If there's a way to fix this, I'm in.

4 Comments - Linear Discussion: Classic Style
  • Can you run it in your secondary monitor ok?

  • Try deleting prefs.prop from the game folder before you launch.

  • User Avatar Image
    Kevin Telltale Staff

    You'll likely need to run in a window. There is little we can do to help your problem, as it is a DirectX/Video driver issue. Can you run other fullscreen games in portrait mode?

  • User Avatar Image
    Sar

    @jp-30 said: Can you run it in your secondary monitor ok?

    Curiouser and curiouser - I'd switched back and forth to and from landscape mode twice while trying to get the demo to run in the first place; once to landscape to try it, once back to portrait to see if it really didn't work there, back to landscape to play through the demo then back to portrait to get an accurate descrition for my initial post, and it kept failing.

    I can't run the game on my secondary monitor, 'cause the launcher starts the game window and the launcher always launches it on the primary monitor (in retrospect I think this is my 'open new windows on monitor x' setting, but it doesn't matter) - however, dragging the launcher to the secondary monitor and launching the game from there brings it up on the primary monitor fully working! Moreover, since this happened I've been unable to reproduce the problem in portrait mode at all!

    Bizarre, but I'm not complaining. ;-)

    @jp-30 said: You'll likely need to run in a window. There is little we can do to help your problem, as it is a DirectX/Video driver issue. Can you run other fullscreen games in portrait mode?

    No, anything fullscreen will always revert to non-portrait, but I don't play many games on my PC (more of a console gamer these days) and I don't mind playing in windowed mode when I do, and I think this is the first time I've met something which minded the monitor orientation when windowed. (Sam and Max started up in windowed mode without me having to do anything the first time it ran, as it goes.)

    Thanks for the help! Now where did I put my credit card...

Add Comment