User Avatar Image

Solutino to activation issues: Internet Explorer

posted by Krid on - last edited - Viewed by 99 users

Hi everybody!

Thought I'd just post the solution to activation troubles: Internet Explorer must be set as your default browser during activation! If something else, like Firefox (version 3.5.4 in my case), is your default browser, activation simply won't work and result in "CONNECTION_ERROR"!

@Telltale support: This hint really should be your standard reply to all activation problem posts and it should definitely go to the FAQ, if it isn't yet there. (I didn't see it, at least.) And, BTW, I don't think it's good programming practice to require IE for activation. At least the program should call IE directly, instead of referring to the default browser, if it relies on IE-only featuers.

Bye, hope I could help some folks,
Krid.

1 Comment - Linear Discussion: Classic Style
  • [quote]At least the program should call IE directly, instead of referring to the default browser, if it relies on IE-only featuers.[/quote]

    It does. You need to have IE installed, but IE doesn't have to be your default browser.

    The CONNECTION_ERROR message occurs if your computer isn't able to contact the activation server, which sometimes occurs due to firewall or internet security settings, or is sometimes due to temporary problems with the activation server. The fact that switching your default browser seems to have solved the issue you were having was probably a coincidence.

Add Comment