User Avatar Image

Mac Installation Issue with Non-Administrator User Account

posted by chrisv on - last edited - Viewed by 283 users

First off, thanks for releasing Monkey Island for the Mac!

I use a non-administrator account on my Mac. Normally, when I need to install an application to my /Applications folder, Mac OS X prompts me for the username and password of a user with administrator privileges. Successfully providing these credentials results in the application being copied over. After the application has been copied, I can launch and run the application without any further authentication or issues.

Dragging Launch of The Screaming Narwhal into my /Applications folder prompts me for the username and password of an administrative user. After I supply these credentials, the game is copied into my /Applications folder. However, when I go to my /Applications folder, the game is displayed as a folder with a red minus icon in the lower-right (see attached screenshot Finder.png). Attempting to launch the game results in a popup window with the message: "You can't open the application MonkeyIsland101 because it may be damaged or incomplete." (see attached screenshot Snap.png)

Lastly, I'll add that copying the game into a folder for which I don't require elevated privileges works correctly. This is currently how I have Monkey Island installed so I can play.

4 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Seg

    Have you tried copying the game into \Applications\ after you copied the game to your own folder?

  • Thanks! I just tried your workaround and it seems to work. Monkey Island now shows up correctly /Applications and launches without error. Are there permission issues with the current DMG file that are causing the issue when copying directly?

  • User Avatar Image
    Seg

    Looks like the build script needs to set the everyone permissions. But for now, here's what you need to do:

    0) Open \Applications\Utilities\Terminal.app
    1) Type the following line in and hit enter:
    chmod -R 755 \Applications\MonkeyIsland101.app

    I'm assuming the file is in the Applications folder. If it's a different location, you can drag-and-drop the file onto the Terminal folder and it will paste the path in.

    1a) If it yells at you for permissions, you'll need to use admin privileges and use this line. If this doen't work, you need to be on an admin account and do this process.
    sudo chmod -R 755 \Applications\MonkeyIsland101.app

    2) Repeat this process for each MonkeyIsland game. You can cheat and hit the UP button once, then edit the 101 to 102 and so on.


    On our side, I'll have to update the build script to set these permissions. The more you know...

  • FYI, I seem to be getting this problem with build scripts for TMI 101 & 103 as of time of post. Running the terminal command does solve toe problem, though, so thanks for the workaround.

Add Comment