User Avatar Image

Adventure Bundle: Can't start Jack Keane

posted by Gatac on - last edited - Viewed by 914 users

Hey,

when I try to start up Jack Keane, I briefly get a black window opening before an error pops up, telling me that the game failed to initialize a Direct3D9 device. It asks whether I would like to continue, but either choice quits me out of it. I have already updated DirectX; all drivers are current. Compatibility mode and running as admin don't seem to make a difference.

Using:

Windows 7 64bit
GeForce GT 240

Here's the Ogre log, from Documents\Jack Keane\logs\ :

---


10:33:23: Creating resource group General
10:33:23: Creating resource group Internal
10:33:23: Creating resource group Autodetect
10:33:23: Registering ResourceManager for type Material
10:33:23: Registering ResourceManager for type Mesh
10:33:23: Registering ResourceManager for type Skeleton
10:33:23: MovableObjectFactory for type 'ParticleSystem' registered.
10:33:23: Loading library OgrePlatform.dll
10:33:23: OverlayElementFactory for type Panel registered.
10:33:23: OverlayElementFactory for type BorderPanel registered.
10:33:23: OverlayElementFactory for type TextArea registered.
10:33:23: Registering ResourceManager for type Font
10:33:23: ArchiveFactory for archive type FileSystem registered.
10:33:23: ArchiveFactory for archive type Zip registered.
10:33:23: DevIL version: Developer's Image Library (DevIL) 1.6.7 Oct 28 2005
10:33:23: DevIL image formats: bmp dib cut dcx dds gif hdr ico cur jpg jpe jpeg lif mdl mng jng pcx pic pix png pbm pgm pnm ppm psd pdd psp pxr sgi bw rgb rgba tga vda icb vst tif tiff wal xpm raw
10:33:23: Registering ResourceManager for type HighLevelGpuProgram
10:33:23: Registering ResourceManager for type Compositor
10:33:23: MovableObjectFactory for type 'Entity' registered.
10:33:23: MovableObjectFactory for type 'Light' registered.
10:33:23: MovableObjectFactory for type 'BillboardSet' registered.
10:33:23: MovableObjectFactory for type 'ManualObject' registered.
10:33:23: MovableObjectFactory for type 'BillboardChain' registered.
10:33:23: MovableObjectFactory for type 'RibbonTrail' registered.
10:33:23: Loading library .\RenderSystem_Direct3D9
10:33:23: D3D9 : Direct3D9 Rendering Subsystem created.
10:33:23: D3D9: Driver Detection Starts
10:33:23: D3D9: Driver Detection Ends
10:33:23: Loading library .\RenderSystem_GL
10:33:23: OpenGL Rendering Subsystem created.
10:33:29: Loading library .\Plugin_ParticleFX
10:33:29: Particle Emitter Type 'Point' registered
10:33:29: Particle Emitter Type 'Box' registered
10:33:29: Particle Emitter Type 'Ellipsoid' registered
10:33:29: Particle Emitter Type 'Cylinder' registered
10:33:29: Particle Emitter Type 'Ring' registered
10:33:29: Particle Emitter Type 'HollowEllipsoid' registered
10:33:29: Particle Affector Type 'LinearForce' registered
10:33:29: Particle Affector Type 'ColourFader' registered
10:33:29: Particle Affector Type 'ColourFader2' registered
10:33:29: Particle Affector Type 'ColourImage' registered
10:33:29: Particle Affector Type 'ColourInterpolator' registered
10:33:29: Particle Affector Type 'Scaler' registered
10:33:29: Particle Affector Type 'Rotator' registered
10:33:29: Particle Affector Type 'DirectionRandomiser' registered
10:33:29: Particle Affector Type 'DeflectorPlane' registered
10:33:29: Loading library .\Plugin_CgProgramManager
10:33:29: Loading library .\Plugin_DotSceneManager
10:33:29: Loading library .\Plugin_TheoraVideoSystem
10:33:29: Registering Texture Controller: Type = ogg_video Name = TheoraVideoPlugIn
10:33:29: *-*-* OGRE Initialising
10:33:29: *-*-* Version 1.2.2 (Dagon)
10:33:29: D3D9 : Subsystem Initialising
10:33:29: ***************************************
10:33:29: *** D3D9 : Subsystem Initialised OK ***
10:33:29: ***************************************
10:33:29: ResourceBackgroundQueue - threading disabled
10:33:29: D3D9RenderSystem::createRenderWindow "Jack Keane", 1024x768 fullscreen miscParams: vsync=true
10:33:29: D3D9 : Created D3D9 Rendering Window 'Jack Keane' : 1024x768, 32bpp
10:33:30: An exception has been thrown!

-----------------------------------
Details:
-----------------------------------
Error #: -2005530516
Function: D3D9RenderWindow::createD3DResources
Description: Failed to create Direct3D9 Device: Invalid call.
File: \work\ExternalProjects\ogrenew\RenderSystems\Direct3D9\src\OgreD3D9RenderWindow.cpp
Line: 596
Stack unwinding: <>

11 Comments - Linear Discussion: Classic Style
  • Game just straight up hangs for me. I get a black screen then the game just stalls forever. Running it on Vista 32 with user access turned off.

    I hope this isn't a DRM thing similar to what is making Whispered World unplayable.

  • I also get a black screen, then an error. I can't even READ the error, just hear the "error message" noise and stay on the black screen. Running XP Media with an Intel 82915G/GV/910GL graphics chipset.

  • User Avatar Image
    kk2

    i get this too.. if you press the windows button, you can see the error message that includes the following messages:

    "Runtime Error!"
    "..\JackKeane.exe"
    "The application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information"

    any help?

  • Hey guys,

    Have you tried making sure you're up to date with your latest graphics drivers and the latest version of DirectX?

    Also, mbacon, how long are you waiting on the game? I've seen it "hang" on a black screen for about 30 seconds or so before it does anything.

  • User Avatar Image
    kk2

    I've made sure I have the latest version of directx and latest driver:

    http://www.intel.com/support/graphics/detect.htm
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en

    And the other game that I have tried, whispered world is working. Any advice?

  • User Avatar Image
    kk2

    Hi, I have the latest graphics driver and direct x installed. I am able to run whispered world and puzzle agent without any problems.

    Is there anything else that I can try? (i have tried uninstall and reinstalling but I have the same issue)

  • User Avatar Image
    kk2

    Hi, would someone be able to assist with this issue/thread?

    thanks in advance

  • User Avatar Image
    DjNDB Moderator

    Can each of you please post a dxdiag log?

    I just did some research on this game. If everything fails you can use OpenGL instead of Direct3D. It is a last resort though. On my system it was significantly slower. It had steady 20 fps, on highest and lowest quality and resolutions, while Direct3D gave me 60 fps limited only by vsync. But it might be different on other systems and could help someone to get it to run at all.

    C:\Program Files (x86)\Telltale Games\Adventure Bundle\Jack Keane\bin\release\plugins.cfg
    Looks like this after installation:
    # Defines plugins to load

    # Define plugin folder
    PluginFolder=.

    # Define plugins
    Plugin=RenderSystem_Direct3D9
    Plugin=RenderSystem_GL
    Plugin=Plugin_ParticleFX
    Plugin=Plugin_CgProgramManager
    Plugin=Plugin_DotSceneManager
    #Plugin=Plugin_OctreeSceneManager
    Plugin=Plugin_TheoraVideoSystem

    If you comment out Direct3D with a # it uses OpenGL.
    #Plugin=RenderSystem_Direct3D9

    I attached an original and a modified plugins.cfg, so you can try it out easily or undo the modification.

    dxdiag
    Windows XP: Go to your start menu and click on run. Type in "dxdiag" and hit enter
    Windows Vista / 7: Press the windows key on your keyboard or click on the start menu. Type in "dxdiag" and hit enter.

    Now click on the button that says "save all information".
    It will prompt you to save a file. Save it where you can find it.

    Then zip the file and attach it to a reply in this Thread.

  • User Avatar Image
    kk2

    Thanks DjNDB, Commenting out that line works! I can run and play

    ...attached is my dxdiag

  • User Avatar Image
    DjNDB Moderator

    @kk2 said: Thanks DjNDB, Commenting out that line works! I can run and play

    That's great. How is the 3D performance?

    Card name: Mobile Intel(R) 945 Express Chipset Family
    Driver Date/Size: 2/15/2008 13:12:06, 57344 bytes

    You have one of those weak intel graphics chips. Since that's already the latest driver, unless running the DirectX updater does anything good, i don't know what else could help. Running with OpenGL might be the only option with some Graphics chipsets.

    Description: Realtek HD Audio output
    Date and Size: 12/9/2005 04:48:40, 4123136 bytes

    You should really update your Realtek HDA Driver.

Add Comment