User Avatar Image

monkey is not running

posted by MacRagnar on - last edited - Viewed by 395 users

Hi there,

i have a problem with all chapter of monkey. When i will start on of the chapter, a window get open but its just in white. But sometime it nothing happend and only the icon jumps in the toolbar.

My Specs:

iMac 2 Ghz Intel Core 2 Duo
Mac OS X 10.6.4

greetz MacRagnar

9 Comments - Linear Discussion: Classic Style
  • I gotta say I laughed at the title

    I'm guessing your using the on-board intel graphics chipset? it's known to have compatibility issues with TTG's games. Usually tho it just makes them run really slow (I had a similar issue though with another incompatible card on my windows PC when I played ToMI)

  • ATI Radeon is known to have issues with TTG games. If you happen to have an Nvidea or other non-ati onboard video, try that. I have to switch from my ATI cards to my Nvidea chipset to play TTG games. (not too familiar with Mac hardware, so if this isnt an option, I'm afraid I dont know what to say other than perhaps to try an external USB graphics card (though you will likely have major issues with cutscenes, the games themselves will be playable)

  • User Avatar Image
    Macfly77 Moderator

    @MacRagnar said: My Specs:

    iMac 2 Ghz Intel Core 2 Duo
    Mac OS X 10.6.4


    Actually, those are the exact specs of my iMac and the games launch without a hitch for me.
    I haven't played through any of the Mac versions (I played through the games in CrossOver Games before they were released for Mac) but The Penal Zone (the only episode of The Devil's Playhouse I've had a chance to play - and finish - so far) ran with no problem.

  • User Avatar Image
    DjNDB Moderator

    Did you download the games recently? There were launch issues which were fixed with an updated version, shortly after release.

    @Ashton said: ATI Radeon is known to have issues with TTG games.

    Which Radeon? I only read about problems with ancient models, especially the Radeon 9000 series.
    I'm playing on a Radeon 4850 myself.

  • @DjNDB said: Which Radeon? I only read about problems with ancient models, especially the Radeon 9000 series.
    I'm playing on a Radeon 4850 myself.

    I know from experience my Radeon X1300 doesn't work and I'll have to go look up the model of my other radeon card that wont work... seems like I've read about at least 5-8 models on this site that don't work with the TTG games

  • @DjNDB said: Did you download the games recently? There were launch issues which were fixed with an updated version, shortly after release.
    .

    I`ve load this things at 09/22/10.
    I think that must be the new version. i dont know what can i do. It is not possible for me to change my graphic card, because it is an iMac.

    apart from that I'm not ready for a game which cost me 5 dollars to replace my video card.
    I think that there is another solution must be.

    greetz from Cologne

    MacRagnar

  • User Avatar Image
    DjNDB Moderator

    @Macfly77 said: Actually, those are the exact specs of my iMac and the games launch without a hitch for me.

    I had a random idea. One difference between your Systems might be the Language settings which caused trouble at some point for puzzle agent.
    In lack of better ideas i would give that a try here too.

  • what a mess. i switch the language but the problems are the same.

Add Comment