User Avatar Image

Sam&Max 3xx and Linux >= kernel 2.6.35

posted by oimel on - last edited - Viewed by 147 users

Hi everyone,

I really liked playing through Sam&Max Season 3 with Ubuntu/Wine. Now I upgraded to kernel 2.6.35 and this seems to break Telltale's Securom protection again: It says "Could not activate security module" with error "3000". (And I'm still missing the fifth chapter as I updated before I could play it!)

There is also a bug filed to wine's bugzilla (http://bugs.winehq.org/show_bug.cgi?id=7065), but it is not yet helpful in solving the problem.

Does anyone have the same problems and/or even any solutions?

Regards!

4 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator

    The obvious workaround is also mentioned in the bugzilla entry. Run the game with an earlier kernel, until the issue is fixed.

    In Ubuntu older kernels are usually still available. You can select them in the grub menu. Depending on your Ubuntu Version it either shows automatically, or you have to hold down the SHIFT key while booting.

  • Thanks for your reply.

    Of course I tried this, but for unknown reasons I lost my nvidia kernel module for kernel 2.6.32 and I cannot recompile it because the needed kernel header files are not installed anymore.

    So the only workaround for me would be:
    1. Install the kernel headers from an older ubuntu version
    2. Try to recompile the nvidia kernel module for this older kernel.

    As nothing works like expected on the first try I shy away from doing this. I thought someone had found an easier workaround and I could save my time.

    Nonetheless this seems the only solution and I will report if it worked. Perhaps it will be helpfull to enyone having the same problem.

  • Yes, same issue here. After 2.6.35 the SecuROM thinks something goes wrong. With NVIDIA binary blob or the nouveau drivers. We should probably bisect the kernel commit breaking this and ask on linux-kernel mailing lists about the issue.

  • Finally I managed to install the kernel 2.6.32 with headers and could compile the nvidia kernel module. And: It really works for Sam&Max (and probably other Telltale games).

    I'm really wondering which internals of the new kernel cause this problem?

Add Comment