Menu
User Avatar Image

Whispered World is excruciatingly slow

posted by manuel calavera on - last edited - Viewed by 289 users

Hey all,
I finally found some time to play this game, even though I purchased the bundle when it came out.
My computer seems to meet the recommended system requirements; however it takes FOREVER for the game to load up. Even after the main menu loads up after several minutes, I have to wait another few for cursor to become movable. Anyone has this issue? It's weird, TWW doesn't seem to have the graphic adjustment option...
my specs are:
AMD 64 Processor 3800+
1.80 GHz, 960 MB of RAM
GeForce 6150 LE

5 Comments - Linear Discussion: Classic Style
  • @manuel calavera said: Hey all,
    I finally found some time to play this game, even though I purchased the bundle when it came out.
    My computer seems to meet the recommended system requirements; however it takes FOREVER for the game to load up. Even after the main menu loads up after several minutes, I have to wait another few for cursor to become movable. Anyone has this issue? It's weird, TWW doesn't seem to have the graphic adjustment option...
    my specs are:
    AMD 64 Processor 3800+
    1.80 GHz, 960 MB of RAM
    GeForce 6150 LE

    I have this issue with ToMI on my home computer when I'm running other applications, when I close them it runs fine. Even my tiny screenshot tool makes it run slow.

    Could you try playing with all other application closed?

  • @Amy Lukima said: I have this issue with ToMI on my home computer when I'm running other applications, when I close them it runs fine. Even my tiny screenshot tool makes it run slow.

    Could you try playing with all other application closed?

    Hey, thanks for the suggestion. I did try that, but the difference is negligible if there is any. By the way, ToMI ran fine on my pc, albeit with reduced graphic options. If only I could adjust them on TWW... Guess, I'll just have to wait when I get a new computer to play this one.

  • I had the same problem as does a lot of people it appears (see here). Whilst its about video stuttering the game ran slow for me as well.

    The only thing that fixed it for me was to use a cracked version (which I do not like doing) of the exe as the DRM cases issues. I cannot give you a link to the crack itself but this post contained an external link to repair files where you will find the fix.

  • Thanks for the suggestion, slake jones. Didn't help though.
    Also, I've updated the video card drivers, since I thought it's probably the card's fault, but that didn't help either. I do remember when I tried the demo, it was kinda slow, but not THAT slow, you know?
    I guess I'll just have to wait for a better rig.
    I'm also having issues with Jake Keane, but I'll make a different thread for it.

  • User Avatar Image
    DjNDB Moderator

    @manuel calavera said:
    GeForce 6150 LE

    @manuel calavera said: I'm also having issues with Jake Keane, but I'll make a different thread for it.

    The Problems With Jack Keane are most likely because you have a quite slow onboard graphics chip. Have you tried reducing the Graphics Quality settings?

Add Comment