User Avatar Image

Sam & Max season 1 on Mac

posted by Jyri Erik on - last edited - Viewed by 183 users

I've tried running it using Crossover Games and Crossover (both demo versions) and while the free episode (104) works, none of the others will get past the activation stage (when I hit the "buy" button it says I have no internet access, so it seems that it simply locks up when I hit the "already paid" button. I've tried the methods on the Crossover boards but they don't seem to work for me. Anyone able to give me a clue as to what I'm doing wrong?

Jyri

9 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    divisionten Moderator

    @Jyri Erik said: I've tried running it using Crossover Games and Crossover (both demo versions) and while the free episode (104) works, none of the others will get past the activation stage (when I hit the "buy" button it says I have no internet access, so it seems that it simply locks up when I hit the "already paid" button. I've tried the methods on the Crossover boards but they don't seem to work for me. Anyone able to give me a clue as to what I'm doing wrong?

    Jyri

    I had the same problem, which is why I ended up not buying Crossover after the trial period ended- but I heard that if you add IE to your bottle for the game, then it will run.

  • s1 is soon going to be ported to mac by the end of the year

  • User Avatar Image
    Macfly77 Moderator

    @divisionten said: I heard that if you add IE to your bottle for the game, then it will run.


    Indeed.
    I posted the instructions in "Telltale tricks" and managed to get every Telltale game to run in CrossOver Games on Mac.

  • Tried those directions, but the install fails due to it telling me I already have a newer version of IE installed. Anything I can do to convince it I don't? (I've tried several ways to set up the bottles, but I assume deleting them would have cleared out that stuff).

    Jyri

  • User Avatar Image
    Macfly77 Moderator

    Just to be clear, you are trying to install IE6 in a brand new bottle and from this installer, right?

    My instructions might be a little outdated as CrossOver Games' interface changed quite a bit in the newer versions.

    What you would need to do:

    1) With Crossover Games open, go to the menu bar, click on "Configure", then "Install software...".
    2) Highlight "Other application" in "Unsupported applications".
    3) Select the installer (ie6setup.exe).
    4) Set the bottle type to Windows 98 (highlight "New win98 bottle...").
    5) Click on "Proceed".
    6) Once Internet Explorer 6 is installed in the bottle, click on the "Configure" menu and choose "Manage Bottles". Choose the bottle you created in the left-hand list. Click on the "Control Panel" tab on the right and double-click on "winecfg". Set the Windows version at the bottom of the window to Windows XP. Click OK to close the window.
    7) Install whichever game you want to play in the same bottle (follow the instructions from steps 1 to 5, replace the name of the installer with the installer of the Telltale game). I used to install each game in its own bottle, but it's not really necessary.

    I know that these instructions are extremely similar to the ones I posted a little over a year ago, but maybe they'll help.
    Good luck!

    NB: While the games are still working for me in the most current version of Crossover Games, I haven't installed any of them from scratch since CrossOver Games 8.0, so maybe something changed in the later versions that prevents the installation from working the way I described. If so, sorry!

  • @mightypiratetm said: s1 is soon going to be ported to mac by the end of the year

    Coolness.

    Is this documented somewhere, or just wishful thinking?

  • @mightypiratetm said: s1 is soon going to be ported to mac by the end of the year

    wait?? if they are porting for mac (soon) then what about PS3 version??? of season 1 and 2??

  • User Avatar Image
    Macfly77 Moderator

    @mightypiratetm said: s1 is soon going to be ported to mac by the end of the year

    @mightypiratetm said: Coolness.

    Is this documented somewhere, or just wishful thinking?

    Back in the February, Telltale did a poll to see which of their games they would port for the Mac next (after TOMI).
    Sam & Max won (they ported season two) and they said that the other games would be made available for Mac within the course of the year.
    Of course, they probably didn't know how much busier they were about to get with Puzzle Agent, Poker Night at the Inventory and the Universal deal.
    At this time, the only one of their older games that has been officially announced for Mac release is Strong Bad's Cool Game for Amazing People.
    The others will probably follow in the not too distant future but I wouldn't expect them before the end of the year.

  • @Macfly77 said: Just to be clear, you are trying to install IE6 in a brand new bottle and from this installer, right?

    My instructions might be a little outdated as CrossOver Games' interface changed quite a bit in the newer versions.

    What you would need to do:

    1) With Crossover Games open, go to the menu bar, click on "Configure", then "Install software...".
    2) Highlight "Other application" in "Unsupported applications".
    3) Select the installer (ie6setup.exe).
    4) Set the bottle type to Windows 98 (highlight "New win98 bottle...").
    5) Click on "Proceed".
    6) Once Internet Explorer 6 is installed in the bottle, click on the "Configure" menu and choose "Manage Bottles". Choose the bottle you created in the left-hand list. Click on the "Control Panel" tab on the right and double-click on "winecfg". Set the Windows version at the bottom of the window to Windows XP. Click OK to close the window.
    7) Install whichever game you want to play in the same bottle (follow the instructions from steps 1 to 5, replace the name of the installer with the installer of the Telltale game). I used to install each game in its own bottle, but it's not really necessary.

    I know that these instructions are extremely similar to the ones I posted a little over a year ago, but maybe they'll help.
    Good luck!

    NB: While the games are still working for me in the most current version of Crossover Games, I haven't installed any of them from scratch since CrossOver Games 8.0, so maybe something changed in the later versions that prevents the installation from working the way I described. If so, sorry!


    Went to the link you gave, downloaded the file & when I tried to install it into a new bottle, I received the "Setup has detected a newer version of Internet Explorer already installed in this system. Setup cannot continue" error message again. For whatever reason it won't install IE 6, despite me not having any version of IE in the currently listed setups.

    Jyri

Add Comment