User Avatar Image

BTTF for Mac (in English) is a non-starter. Anyone else has this problem ?

posted by wigglebritches on - last edited - Viewed by 219 users

Hello,

I downloaded the first episode of the BTTF game onto a MacBook, running on Mac OS 10.6.5.
Every time I click on the "Play" button, the program quits.
Is this a known bug, or am I missing something ?

6 Comments - Linear Discussion: Classic Style
  • Hey there!

    At least you get to see a "Play" button, everytime I double click the app in the Finder literally nothing happens...

    Edit: Now it works, I just cleaned up my Mac (Caches etc.) and now the game works properly.

  • I'm having the same problem. - I dont even get a Play Button. Between two Macs, Three PCs, PS3, Wii, Nintendo DS, PSP, GameCube, N64, X-Box and every other little gadget in my house I've never in my life had such a problem starting a game.

    Ive deleted the download, redownloaded and that set me back even more. Now I cant even get the flash screen that shows the episodes.

    I'm ready to demand a refund for this junk

  • I downloaded the game from the window that popped up when I visited Telltale.com. Unzipped the file and ran "BackToTheFuture101 DRM 15.05.app", hit play and it re-downloaded episode 1 but got stuck at 100%. Quit out and tried to open it again and it would crash each time I tried that. So I deleted that file and re-downloaded from the location under 'My Games', that time I got a file just named "BackToTheFuture101.app". I opened that and hit play on the episode, no downloading and it just worked.

    So I would suggest deleting the old file and re-downloading from "My Games"

  • @JayCGN said: Hey there!

    At least you get to see a "Play" button, everytime I double click the app in the Finder literally nothing happens...

    Edit: Now it works, I just cleaned up my Mac (Caches etc.) and now the game works properly.

    Same thing is happening for me. The app just won't start when clicking on the icon. What did you do exactly to start the game?

  • I can start the App, but only if I turn off my wireless connection first.
    Otherwise, the page loads up without any text, and I can't start it.

  • I had this same problem. I just downloaded the file again and it's working now.

Add Comment