User Avatar Image

BTTF Mac : crashes at startup

posted by AxelTerizaki on - last edited - Viewed by 339 users

Hello.

I downloaded the first episode this morning, the .zip is 400Mb big and inside is just an application.

When I double-click on it, it crashes without showing me anything, and I get the following report :

Process: Mac_Game [8171]
Path: /Users/aterizak/BackToTheFuture101.app/Contents/MacOS/Mac_Game
Identifier: com.telltalegames.BTTF101
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [124]

Date/Time: 2010-12-23 10:39:02.393 +0100
OS Version: Mac OS X 10.6.5 (10H574)
Report Version: 6

Interval Since Last Report: 3532 sec
Crashes Since Last Report: 8
Per-App Crashes Since Last Report: 7
Anonymous UUID: 710D3B01-0544-4040-901C-46D98F4E7E2A

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/QtWebkit.framework/Versions/4/QtWebkit
Referenced from: /Users/aterizak/BackToTheFuture101.app/Contents/MacOS/Mac_Game
Reason: image not found

Binary Images:
0x8fe00000 - 0x8fe4162b dyld 132.1 (???) /usr/lib/dyld

Someone help? ^^

8 Comments - Linear Discussion: Classic Style
  • I didn't check the report, but mine crashed after I tried clicking the app icon, too. I found that if I extracted the app using the built-in archive utility, instead of Zipeg (which I usually use), then I can open it.

    Still, once I open it, it will download the episode for about an hour, and then start over. But maybe you'll have better luck than I'm having.

  • Nope, I used the built-in extractor toopen the zip file, and the.app inside looks okay to me.

  • Mine crashes with "Permission denied".

  • I made it work! I'm not sure the same thing will work for everyone else though. It basically was a permission issue for me.

    Open up a terminal (Applications>Utilites>Terminal) and enter the following lines (you'll be asked for your password). But make a copy or keep the original .zip first, just in case.

    cd /Applications
    sudo chown -R root BackToTheFuture101.app/
    sudo chmod -R 755 BackToTheFuture101.app/

    This is basically to make the owner of the application be root (it seems it's the same in other ones) and then to give executing permissions to everyone.

    EDIT: To Telltale people:
    Please consider using .dmg files instead of .zip, I think it helps maintain the intended permissions.

  • This didn't fix my problem in my first post, sadly.

  • I too have the same problem, on trying to run the app, I get the standard "This application cannot be launched because of a problem" dialog.

    Inspecting the report reveals exactly the same error message as the original post.
    I have tried extracting with different unzippers (no joy).
    I have tried modifying the permissions on the App (no joy).
    I have run the Software updater (no joy). I am on fully updated Snow Leopard

  • I think I have found the problem. I have strict case sensitivity enforced on my Mac. (Because *I* can type. TellTale, take note).

    The report has the path specified as

    @executable_path/../Frameworks/QtWebkit.framework/Versions/4/QtWebkit

    where as the actual directory structure is
    /Frameworks/QtWebKit.framework/Versions/4/QtWebKit

    TellTale, I think the archive has to be redone with the correct capitals.

    For those of us not willing to wait, the following fix works:

    Option Click the unzipped app, and select "Show Package contents"
    rename 2 files and 1 directory to have a lower case k
    /Frameworks/QtWebkit.framework
    /Frameworks/QtWebkit.framework/QtWebkit.prl
    /Frameworks/QtWebkit.framework/Versions/4/QtWebkit

  • I'm impressed. I didn't think about this, but I had the same kind of problem with Steam just the other day when I installed it on this old Macbook.

    I thank you for this, really :)

Add Comment