User Avatar Image

Back to the Future Not launching Bug?

posted by kruz on - last edited - Viewed by 203 users

I just installed the BTTF game and it launched fine on first run. The game crashed on me and I had to restart it. When I click "play" nothing happens. When I rebooted and tried again nothing happens.

I'm running Windows 7 64 bit. I'm sure this may apply to Windows Vista as well. In order for me to get the game to play at all. I need to right click on the Launcher and click on Run as Administrator. This is ridiculous IMO because not all kids/teens are going to have admin privileges on their parents computers and there's NO reason why a launcher should need admin rights.

If you are having trouble launching the game and you are on Win7/Vista. Try right click->run as admin and see if the game launches when you click play.

2 Comments - Linear Discussion: Classic Style
  • @kruz said: I just installed the BTTF game and it launched fine on first run. The game crashed on me and I had to restart it. When I click "play" nothing happens. When I rebooted and tried again nothing happens.

    I'm running Windows 7 64 bit. I'm sure this may apply to Windows Vista as well. In order for me to get the game to play at all. I need to right click on the Launcher and click on Run as Administrator. This is ridiculous IMO because not all kids/teens are going to have admin privileges on their parents computers and there's NO reason why a launcher should need admin rights.

    If you are having trouble launching the game and you are on Win7/Vista. Try right click->run as admin and see if the game launches when you click play.



    I had the same problem. Thanks to the above poster for the solution.

    You guys at Telltale need to fix this. Requiring admin privileges to play the game is ridiculous.

  • I also had the same problem. The play button does nothing. Not even a message saying "You must have admin privledges to run game".

Add Comment