User Avatar Image

backtothefuture103.exe has stopped working

posted by trusto on - last edited - Viewed by 153 users

hello
I have an urgent problem to be solved ...
I downloaded the 3rd party citizen brown, but when you start loading and eventually Chud and leaves the message: "BACK TO THE FUTURE 103 EXE has stopped working!"
The first two episodes work, do not understand why this no!
I checked the requirements and I have!
my pc and a laptop vaio ...

4 Comments - Linear Discussion: Classic Style
  • Hey Guys - I have had no problems installing and playing the first two episodes of BTTF but this third one won't start. I have tried installing and re-installing it several times and it always crashes in the same spot when I start the game: I see the flux capacitor in the bottom right and I hear the opening sound effect twice before it crashes - and I get the Windows Vista message BackToTheFuture103.exe has stopped working. I have also tried running both the install and game launch as administrator but the same thing happens. Any advice? Thanks in advance.

  • on my pc the ep 3 dont work!!
    episode 3 on my pc is not working ....
    When the load gives me the error: "has stopped working and then closes!"
    I installed the first two and I work!
    What can I do?

  • User Avatar Image
    puzzlebox Telltale Staff

    Do you guys have any other programs running when you try to run the game? Try closing everything (here's how to do a clean startup) and see if the game will run then.

    If it's still crashing, send an email to support@telltalegames.com. It would probably help the support people out if you could include your DXDiag info in the email text (they can't receive attachments).

  • Sorry for the delayed reply - was visiting family the last few days.

    No - I don't have any other programs running at the same time, unless you count AVG, SnagIt or my HP printer. These were all running with the first two episodes (although my printer is now a newer model but still HP). I also have a Sony Vaio... getting a Dell next week - so maybe I'll wait and test it on that...

    Otherwise I will send the request to Support.

    Thanks :)

Add Comment