User Avatar Image

Puzzle Agent 2 - Stacks of Flyers

posted by CaptPicard on - last edited - Viewed by 963 users

I'm playing Puzzle Agent 2, and have reached the "Stacks of Flyers" puzzle. I quit out of the puzzle, and when I went back into it, the numbers in the puzzle had not reset. When I went to try and solve the puzzle, the numbers would increase from the non-reset numbers, and when I tried to reset, they only went back to when I re-opened the puzzle. I tried a second time with the same result. I don't think this is the normal behavior.

I wanted to include a screenshot, but Alt+Print Screen wasn't working for me. :(

16 Comments - Linear Discussion: Classic Style
  • I'm seeing the same problem after having completed the game and going back to the puzzle in free-play mode.

    Game purchased direct from TTG. Mac OS X 10.6.8.

  • spoiler...

    in this puzzle I got rejected despite having a minimum of 50 fliers because it wasnt the 'right' answer. I had the two black numbers add up to 27 (cant remember which as I have the same problem as above) and the 3 red numbers were 11, 12, 12. Which ever '?' path the bandit takes, its still 27+23 or 27+24.
    Unless i'm missing the point I dont see why all 3 red numbers have to be 12

  • I think it's actually supposed to be exactly 50, not minimum.

    Also I fixed it with cheat engine, but still, bug heads up.

  • User Avatar Image
    Blitzci Telltale Staff

    We saw this bug in testing, and I thought we'd done a pretty bulletproof job of fixing it...

    It sounds like quitting and re-entering the puzzle makes the bug go away (though it can happen again), so at least it should be possible to get past this puzzle if you quit and try again every time the bug happens. Obviously it's still pretty annoying, though...

    We'll try and reproduce the bug on our end. If anyone can describe in detail how it happens (as in, a sequence of moves that causes the bug to occur), that'd help me find it.

    Incidentally: when I encountered this bug in testing, I found that, even if the numbers were glitching, the puzzle would still accept the answer if the stacks were all in the right places. That may still be the case! Admittedly, it's no substitute for a properly functioning puzzle...

  • I'm starting over the game after running into this bug to try to find a way to reproduce it with as little steps as possible.

    In the mean time, here is a save file with the bug in question:

    http://dl.dropbox.com/u/3990981/save1.save

    Its at the point where if you walk up to the puzzle, it displays the old numbers from my original attempt.

    Don't know if that specifically helps, but I figured I'd upload it just in case.

  • User Avatar Image
    Blitzci Telltale Staff

    That does help! Unfortunately it also tells me that quitting and restarting the puzzle, or even quitting the game and reloading the save, doesn't make the bug go away, which is bad.

    I can at least affirm that the puzzle accepts your answer, regardless of what the numbers say, if all the flyers are in the right place. But that forces the player to do all the math themselves, which makes the puzzle a little harder than we wanted it to be.

    Let me know if this makes sense to anybody: It seems to me that the bug occurs when you quit the puzzle. The numbers at the bottom of the puzzle get "stuck" at whatever value they were showing when you quit, and that value becomes their default (which should be zero).

    So... for now, I guess the way to avoid this bug is not to quit the puzzle. Or, if you must quit the puzzle, move all the flyers to the empty spaces on the right side of the puzzle screen, so that all the numbers are set to zero.

  • @Blitzci said: It sounds like quitting and re-entering the puzzle makes the bug go away (though it can happen again),

    On the contrary, it seems that's how the bug is triggered and manifested. I have quit not only the puzzle but shut down the entire game, and when I relaunch and go back to the puzzle, there are always numbers already in the boxes at the bottom of the puzzle, the same ones that were there the last time I left, whether I left by clicking Submit or Quit. When I move the number-pieces from the right into the boxes at the top, values are added to the existing numbers in the bottom boxes. The problem is cumulative every time I leave the puzzle, and at this point the numbers in the bottom boxes are in triple digits.

    flyers.png

    It is the case that if the number-pieces are in the correct positions when clicking submit, the puzzle registers as being solved correctly, even though the numbers in the bottom boxes are way off.

    FWIW, I solved the puzzle correctly, and without quitting in the middle of it, the first time I played through the game. I noticed the problem after coming back to the puzzle afterwards in free-play mode.

  • Here is my method of reproducing the bug.

    ▼ ❑ Start a "New Game"
    • ❑ I used a fresh install
    • ❑ I used the first player slot
    ▼ ❑ Moon Focus
    • ❑ Drag the outer dial up two notches
    • ❑ Drag the inner dial down two notches
    • ❑ Press "Submit"
    • ❑ Press "Okay" after the solution is accepted
    ▼ ❑ Nelson Tether's Office
    • ❑ Talk to Agent Ingraham
    • ❑ Select "Trespassing"
    ▼ ❑ Monosaki Puzzle #320
    • ❑ Press 3
    • ❑ Press "Submit"
    • ❑ Press "Okay" after the solution is accepted
    ▼ ❑ Scoggins
    • ❑ Enter Valda's Inn
    ▼ ❑ Valda's Inn
    • ❑ Speak to Mrs. Garret
    • ❑ Select "Vacancy"
    ▼ ❑ Finding Vacancy
    ▼ ❑ Use this Solution
    5AJw0.jpg• ❑ Press "Submit"
    • ❑ Press "Okay" after the solution is accepted
    ▼ ❑ Valda's Inn
    • ❑ Leave the Inn
    ▼ ❑ Scoggins
    • ❑ Enter the Alley
    ▼ ❑ Inn Room
    • ❑ Select the bed
    ▼ ❑ Missing Persons
    • ❑ Press "Submit"
    ▼ ❑ Scoggins
    • ❑ Speak to Darryl
    • ❑ Select "Fliers"
    ▼ ❑ Stacks of Flyers
    • ❑ Set up some a "solution", but don't submit it
    ▼ ❑ I used this solution
    R0xHy.jpg• ❑ Press Quit
    ▼ ❑ Scoggins
    • ❑ Speak to Darryl
    • ❑ Select "Flyers"
    ▼ ❑ Stacks of Flyers
    • ❑ The totals have not been reset
    ▼ ❑ This was my result
    1Esyt.jpg

    Here is the save file produced if you follow all the above steps:
    http://dl.dropbox.com/u/3990981/ToTelltaleWithLove.save

  • I submitted an in depth explanation of reproducing the bug, but I have to wait for it to be approved by a moderator before it'll post (I think since I added pictures). I also have the save file from using the process too.

    I don't know how long that process takes, but I can PM it to you as well if you'd like.

    From what I've seen repeatedly playing up to this bug I have made a few observations:

    1. These variables seem to be defined globally and instantiated to zero.
    2. The function(s) starting the puzzle never set the variable to zero. Rather than set the variable to zero each time the puzzle is started, it assumes the variable is zero at the start.
    3. The function that does the math for these variables seems to include the variable itself.
    I.E. A=A+X/2;
    This is because it never corrects itself when the player tries to solve the puzzle again. Instead, you can repeat the process of quitting and restarting to make the values extremely large. This isn't a problem by itself, but why we can continually grow the value of the variable over time.
    4. The function(s) handling the quitting process for the puzzle never sets these variables back to zero.

    Thats my theory on what the problem is anyways. =)

Add Comment