User Avatar Image

Problem Opening all my Telltale Games (Mac)

posted by jackdack on - last edited - Viewed by 154 users

When I open any of the games I've purchased this is what I see.

attachment.php?attachmentid=2672&stc=1&d

I can see the bits where I need to log in, but I can't click on those boxes to type. Nothing loads properly. I've opened them on a PC and they're fine. Can you help me figure out what the problem is?

Running Mac OS X 10.6.8 on a 2.2GHz Intel Macbook Pro. 2GB memory.

Thanks.

9 Comments - Linear Discussion: Classic Style
  • Same here looks like TTG website is having issues and that is preventing from launching game. I wanted to complete BTTF episode 5 ant I just have a black screen and can't launch the game :S

  • User Avatar Image
    puzzlebox Telltale Staff

    wedge, you may be having the same problems with the launcher that some other people have mentioned. If the launcher sees an internet connection but can't contact the Telltale site, it will just sit there trying to load forever. If you've already activated the episode online, try disabling your internet connection and then loading the launcher again.

    jackdack, I'm not sure if the same thing will help you (especially since it looks like you need to log in to activate the game first). Do you have a firewall or anything that's blocking the launcher from connecting to Telltale?

  • @puzzlebox said:

    jackdack, Do you have a firewall or anything that's blocking the launcher from connecting to Telltale?

    I don't have a firewall blocking problem, as far as I know. I had to mess with my firewall a long time ago when I first hooked up my Wii to my wifi. But I don't have a problem with any other programs or games that need to hook up to the internet. Just the games here.

    But just to make sure, if it was a firewall thing, how would I fix it?

  • User Avatar Image
    puzzlebox Telltale Staff

    You could try specifically enabling the game in your firewall rules, or disabling the firewall just long enough to register the game (you should only have to do that momentarily and then you can turn it on again).

    I've also seen suggestions from TTG for refreshing the Mac launcher here and here. Seems that solution didn't work for those users, but it might be worth a try anyway.

    If the launcher does load ok when you're not connected to the internet, you should be able to request an offline unlock code from support@telltalegames.com.

  • My firewall is turned off and it still comes up exactly the same. I tried the resetting thing you mentioned and it didn't work. :/ Any other ideas what the problem might be?

  • User Avatar Image
    puzzlebox Telltale Staff

    Sorry Jack, that's about all I got. :(

    Hopefully one of the TTG people (or some other helpful soul) will have more.

  • User Avatar Image
    DjNDB Moderator

    I don't have much Mac experience, but maybe the solutions from a similar issue with Back to the Future could help.

  • Unfortunately none of the solutions from that thread seemed to work. But thanks for trying to help. I appreciate it.

  • This thread has existed since July of 2011, and the problem described here has not been resolved. I assume jackdack never got to play his games.

    This upsets me because I'm having the exact same problem, which I've posted about else where on this forum, and none of the trouble shooting I've found on this message board has worked.

    I'm starting to think that I'm never gonna be able to play my games...

Add Comment