User Avatar Image

Steam Wallace and Grommit & Sam & Max Seasons 1-2 all crash

posted by AGetzler on - last edited - Viewed by 88 users

I stocked up on Sam and Max and Wallace and Grommit on Steam while they were on sale.

I can only get Season 3 of Sam and Max to run on my PC. All the rest (Seasons 1 and 2 and all the Wallace and Grommit games) crash at startup.

I'm running XP up to date, and DirectX 9.0.c.

Sample crash notice and dxdiag enclosed.

What changed between seasons 2 and 3 to make the games work?

3 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator

    Card name: NVIDIA GeForce 9500 GT
    Driver Date/Size: 4/3/2010 17:55:31, 6432128 bytes

    Description: Realtek HD Audio output
    Date and Size: 3/30/2009 20:13:30, 5063168 bytes



    You do have some quite old drivers. Please try if installing the latest Nvidia driver and Realtek HDA driver fixes the problem.

  • I've updated both my NVidia and Realtek drivers for XP 32 bit.
    No change.

    AppName: sammax101.exe AppVer: 0.0.0.0 ModName: sammax101.exe
    ModVer: 0.0.0.0 Offset: 00365dd0

    Revised dxdiag attached.

    Is there a way I could capture the dump transmitted to Microsoft? I can't copy off its scrollable dump details.

  • User Avatar Image
    DjNDB Moderator

    You can look for crash information in the event viewer.

    Next thing i would try is starting the games during a clean boot:

    Booting clean in Windows XP:
    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Process SYSTEM.INI file
    4. Uncheck Process WIN.INI file
    5. Uncheck Load Startup Items
    6. Click on the Services tab
    7. At the bottom, check Hide All Microsoft Services
    8. Uncheck all boxes in the window or click the button labeled Disable All
    6. Click OK
    7. Click Restart
    8. After reboot, run the game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click OK
    4. Click YES, when asked to restart your computer

Add Comment