User Avatar Image

Hector 2 wouldn't install to my phone?

posted by Saber on - last edited - Viewed by 187 users

Okay, so I just purchased Hector 2, and when I tried to install it to my iPhone, it said that it requires a newer version of iPhone software? My phone is 3Gs and I had no problems with the first Hector. My software version is 4.0.1.

Man, if I had known this would happen, I should have never bought this!

5 Comments - Linear Discussion: Classic Style
This discussion has been closed.