User Avatar Image

Sam and Max DVD Problems

posted by dualloop on - last edited - Viewed by 558 users

Hello,
I recently received Sam and Max Season One through the post.
But for some reason, none of the episodes will start.
The cursor doesn't show the Disc symbol that appears just before the game starts.
The computer will recognise when the disk is not in the drive if i start a game without the disk in the drive and it does read the disk on windows explorer.
The DVD is not faulty as i've installed and played the episodes on my laptop.
I'm unable to terminate the process in task manager as it will not display on screen, and only show an icon in the taskbar, also, i cannot restart or shut down the computer, so i have to shut it down myself.

My Specs:
Windows Vista Home Premium
Intel Core 2 Duo E6600 2.4GHz
4GB RAM
XFX Nvidia Geforce 8800 GTS 640MB
Creative Sound Blaster X-FI ExtremeGamer.

Any help would be greatly appreciated.

13 Comments - Linear Discussion: Classic Style
  • Do you know what brand and model your DVD reader is? This sounds like your reader is having difficulty reading the DVD-ROM because of an unproperly supported disc format. It might help to update the driver.

    Also, another person had a very similar problem where they couldn't read the disc. They were able to solve the problem by going to "control panel", then "system", and going to "device manager" under the "hardware" tab (Windows XP), and changing the transfer mode for their IDE ATA/ATAPI controller in "advanced settings".

    Your reader is most likely on the Primary IDE channel. Just switch the transfer modes around from their default settings until you've tried them all, it won't hurt anything. But be sure to return them to their original values. :)

  • The DVD drive is a LITE-ON DVDRW.
    Im not sure how to change the transfer mode as i cant find the option under vista.
    I'll try to update the drivers for it if i can.
    Thanks for the help

    EDIT: Updating the firmware had no effect.

  • Oh no, a Lite-On. : / Hmm, well, I'm not sure how to change the transfer mode in Vista. But someone else here should. :)

  • OK :)
    This is the first game i have had problems with, Pity its this one.

  • Anything to report about the problem?

  • Oops, sorry, I missed this thread. :o

    To access the transfer mode in Vista:

    [LIST]
    [*] Right-click on the 'Computer' icon on the desktop.
    [*] Click on 'Properties'
    [*] Click on 'Device Manager'
    [*] Look at the IDE ATA/ATAPI Controller section
    [*] Double-click one of the devices in this section and go to the 'Advanced Settings' tab. On this tab, look at the Device Type to see if it's your DVD drive. (If it isn't, keep looking through the devices until you find it. :D)
    [*] Once you've found your DVD drive, look at the bottom of the window where it says 'DMA'. To change your transfer mode, check or uncheck the box next to DMA.
    [/LIST]

    Please let us know if you're able to do this, and if it solves the problem. :)

  • Hello, i have solved the problem.
    The problem was that my motherboard is SATA II based so only has one IDE slot, but i have 2 IDE CD Drives (DVD and CD) and 2 IDE hard drives. I had to have an ATA Raid card in one of the PCI slots. I had the CD drives connected to the Raid card as the motherboard could not read the operating system from the hard drive when plugged in to the card, Which prevented me from changing the transfer mode as vista could only see the drives in My Computer. So i replaced the Hard drives with a SATA hard drive, removed the raid card and plugged the CD and DVD Drives into the motherboard, re-installed Vista and it worked.
    It seems that the Securom is the only protection system i have used that has a problem with Raid cards, starforce, etc works.
    BioShock uses the same protection system, that also would'nt start, so i knew it must be a problem that securom has with Raid cards.
    Thanks for all the help though!

  • Thanks for posting what you figured out. It makes my head spin, but I'm glad you were able to fix it. :D

  • I am having the blank disk problem. I have Windows Vista, but I am unable to use the solution that Emily posted. There is no IDE ATA/ATAPI Controller section. There is no Advanced Settings tab.

    I don't want to pay anything for a replacement disk or anything to ship the defective disk back. They made the defective product, so they should absorb all of the cost.

  • Did they ask you to pay? I don't believe anyone has had to so far.

Add Comment