User Avatar Image

Help -Update/Episode 3 breaks TWD [MAC]

posted by CB123 on - last edited - Viewed by 315 users

The game is unusable for me too.

I have noticed the following bugs:-

[LIST]
[*]On loading TWD on Mac OS X, it hangs.
[*]Switching to a window, I can see something is downloading something using a network monitor
[*]After 20 minutes, it eventually lets me in
[*]Trying to download Episode 3 hangs at 99.5%
[*]Switching between full screen and window often crashes TWD
[*]Quitting the game when in window mode crashes the game
[/LIST]

Telltale support. Please can you address this asap or even respond.
__________________________________________________________________________________
UPDATE:-

I have found a fix of sorts! Tested successfully by four folks.

What you need is copy the following two directories from a working machine, or a copy from a friend.

/Users/"your user name"/Library/Application Support/Telltale Games/TheWalkingDead/SyncFs/Data/WalkingDead103

and

/Users/"Your user name"/Library/Application Support/Telltale Games/TheWalkingDead/SyncFs/Meta


Copy these two directories onto your own machine with the EP3 problem. Make sure you don't overwrite any other folders.

EP3 then works.

12 Comments - Linear Discussion: Classic Style
  • @CB123 said: The game is unusable for me too.

    I have noticed the following bugs:-

    [LIST]
    [*]On loading TWD on Mac OS X, it hangs.
    [*]Switching to a window, I can see something is downloading something using a network monitor
    [*]After 20 minutes, it eventually lets me in

    This isn't an error but it's downloading a program update without any notification.

    @CB123 said:
    [*]Trying to download Episode 3 hangs at 99.5%
    [*]Switching between full screen and window often crashes TWD
    [*]Quitting the game when in window mode crashes the game
    [/LIST]

    I've got the exact same problems, but the game 'crashes' in fullscreen mode as well when I quit the game. It's not really a crash as I wanted to quit the game anyway, but it's just weird I get a error notice after quitting.

  • Mine crashes in full screen while trying to download Episode 3 :(
    99.5% at other percentages.

  • Does anyone have a working ep3 on the Mac?
    I've tried uninstalling, wiping the settings and files, clean re-install. :(

  • Possible solution. It worked for me! Big thanks to AlfredoSanchez
    Let us all know how you get on guys and girls! :)
    ;)

    See below:-

    Originally Posted by AlfredoSanchez

    "I had this exact same problem, it twice downloading to 99.50% before crashing.

    This is what solved it for me:

    It went into graphic settings and turned everything to low or off (anti-aliasing, the screen resolution, shadow, etc.). I also made it full screen (it wasn't before).

    Suddenly the download now comes in at a phenomenal speed, and completed at 100% in no time.

    Try it yourself. I hope it works for you."

  • Glad this worked for you, but its not working for me. I seem to recall this was offered as a solution for some for Episode 2 problems with limited success.

  • Blackvulcan3: Have you tried starting it up then walking away for 15-20 minutes? That's what finally worked for me. Otherwise there is no Main Menu.

  • Yeah, I found that out early on about the connecting issue, I remembered a simialr thing from episode 2. I'm stuck downloading at 99.50%.

  • @blackvulcan3 said: Yeah, I found that out early on about the connecting issue, I remembered a simialr thing from episode 2. I'm stuck downloading at 99.50%.

    Did you set every graphics setting to it's lowest including resolution set to 640 by 480?
    What model of Mac do you have and which OS x?

  • Make sure you're in full screen mode as well during the ep3 download.

  • Thanks CB123, this solution was thrown around for episode 2. I've tried it on episode 3 about 8 times now, either selecting the download from within the game or from the download content selection from the main menu.

    I have a 27 inch mid 2010 imac 2.93ghz i7 with 8gb ram and 1gb video running 10.7.4.

Add Comment