User Avatar Image

problems with the walking dead on mac (game is blocked at the main screen)

posted by Haggis_McMutton on - last edited - Viewed by 285 users

Hi everybody!

I have a problem.
When I start The Walking Dead game (on Mac OS X 10.7.4) it starts regularly, but after connecting on the main screen, it doesn't take me to the main menu, so I can't start a new game nor download a new episode. It just remains in the main screen where the news roll. Strange thing is that before episode 3 was released, it worked just fine.
Hope I'm not the only one having this problem, and that somebody could help. Cheers.

9 Comments - Linear Discussion: Classic Style
  • Its not broken - its just s**t design.

    Its downloading some massive updates... eventually you will get to the main screen.

    Just Telltales way of saying "f-you" to Mac users!

  • I'm going through the same thing, but according to the response I guess it takes more than 5 minutes to load?!! Guess I'll try to give it 10 or 15 and see what happens. So frustrated.

  • Started it up after clicking Continue. Walked away to do some dishes, for maybe 10 or 15 minutes. Came back and it worked!!! Thanks, RealEvil!

  • User Avatar Image
    DjNDB Moderator

    @ayanna47 said: Started it up after clicking Continue. Walked away to do some dishes, for maybe 10 or 15 minutes. Came back and it worked!!! Thanks, RealEvil!

    That reminds me of the good old C64 days, when games took forever to load :D :(

  • At least on the C64 you could look at the tape counter.....;)

  • @realevil said: Its not broken - its just s**t design.

    Its downloading some massive updates... eventually you will get to the main screen.

    Just Telltales way of saying "f-you" to Mac users!

    yeah, I noticed... started it, gone to do something else, came back, and it was there: the main menu! I got to play, even if it took HOURS to download episode 3 8 (the first time, it got stuck at 99.50%, so I shut everything down and went to bed, this afternoon the download has gone much quicker, but it still got stuck at 99.50%, then, after waiting a few minutes more, it got installed) ... still, everytime I start the game, it takes about 20 minutes to get to the main menu...

  • @Haggis_McMutton said: yeah, I noticed... started it, gone to do something else, came back, and it was there: the main menu! I got to play, even if it took HOURS to download episode 3 8 (the first time, it got stuck at 99.50%, so I shut everything down and went to bed, this afternoon the download has gone much quicker, but it still got stuck at 99.50%, then, after waiting a few minutes more, it got installed) ... still, everytime I start the game, it takes about 20 minutes to get to the main menu...

    Have you found any solution for that problem?

  • not yet, but lately I haven't had (is it correct? "haven't had"? sorry, I'm not english/american...) much time to try to find a solution... as soon as I'll be able to, I'll get working on it :)

Add Comment