User Avatar Image

Sam and Max Season 1 DVD Vista problem

posted by JXS2 on - last edited - Viewed by 484 users

Hiya, I know theres a lot of people posting a similar error but mine seems to be a little more severe. I was getting the "Error accessing system registry" then "Unexpected error; quitting" when trying to autorun the DVD, but then I tried to access it through explorer and it's not showing anything on the DVD at all. I can't even open it.

I tried disabling the User Controls but then when I went to try autorunning it I got a blue screen error and had to physically reset the computer. So I turned User Controls back on and I've tried twice to try install the game but both times I've gotten the blue screen again. I've tested the dvd in my bf's XP PC and it went to the loading screen straight away.

Also I've tried to change the IDE ATA/ATAPI thingy but I don't think I know what I'm doing, it's not clear which one is my dvd writer and none of them seem to be able to change the transfer mode anyways

Specs:
Vista Home Premium
AMD Athlon 64 Dual Core Processor 6000+ 3.01 GHz
RAM 4 gig
NVidia 8800 GTS
LG DVD/RW

thanks in advance!

13 Comments - Linear Discussion: Classic Style
  • have you got the latest drivers for your dvd drive (download from the LG site if possible) (vista drivers are pretty premature at the moment (still love it though))

    and nice computer by the way (was vista preinstalled)

  • Right-click the setup.exe file on the disc and select Run As Administrator.

    It might take a few minutes for the setup to kick in but this has worked for other people experiencing the same problem.

    Never mind, that won't work for you if you can't browse the disc.

    Do you remember what the blue screen said? Sometimes there's a clue on there about what isn't working.

    If this is Telltale's DVD, you can at least use the download versions until we figure out what's causing the problem.

  • The Event Log should have an entry detailing what it crashed on. Trouble is I've never used Vista myself so I'm not how you get at the Event Log with it :)

    Can you browse the dvd directly after reboot (i.e. without trying auto-run or running anything from it, just browsing it)?

  • User Avatar Image
    jmm

    The easiest way to get to the event viewer is to enter "eventvwr.msc" in the run box and hit enter.

    To change the transfer modes, you have to
    1. go to the device manager
    2. Double-click the proper IDE channel (available under IDE ATA/ATAPI controllers)
    3. Change the DMA transfer mode for the correct device under the Advanced tab.
    4. Reboot
    Note: it is possible that the system will ask you for administrative credentials. If you see the controls grayed out, you need to use an administrator account.

    To select the correct channel and device, check your BIOS Post (The screen shown after turning on the computer) for the disk layout (Something like "Secondary Channel Master: ATAPI CD-ROM")
    or use a system information tool (like SIW from http://www.gtopala.com/)

  • @jmm said: The easiest way to get to the event viewer is to enter "eventvwr.msc" in the run box and hit enter.

    To change the transfer modes, you have to
    1. go to the device manager
    2. Double-click the proper IDE channel (available under IDE ATA/ATAPI controllers)
    3. Change the DMA transfer mode for the correct device under the Advanced tab.
    4. Reboot
    Note: it is possible that the system will ask you for administrative credentials. If you see the controls grayed out, you need to use an administrator account.

    To select the correct channel and device, check your BIOS Post (The screen shown after turning on the computer) for the disk layout (Something like "Secondary Channel Master: ATAPI CD-ROM")
    or use a system information tool (like SIW from http://www.gtopala.com/)



    for vista type in "eventvwr" into the start search box

  • HI, I have the same problem as the original poster but found a "kinda" work around. (To reiterate I get the "system registry access" error when attempting to left click the CD or use the autorun launcher). Also, I just got the game, season one, on CD-ROM and I am running Vista Ultimate.


    (I am running as a computer:

    AMD Athlon X2 4400+
    2GB Patriot DDR2-800
    ATI Radeon X1950 Pro PCIE 256MB
    200GB WD Hard Drive
    Lite-ON LH52C1P Ultra ATA DVD/CD-ROM Drive in DMA mode
    Windows Vista Ultimate fully patched)

    1. Go to My Computer

    2. Right Click on the DVD/CD icon and right click

    3. Select "open" from the right click list

    4. Now you will see three files, locate the one called "SAM AND MAX SEASON 1 Setup", it should also have a pic of sam and max as an icon with a windows admin shield on it. Right click on it.

    5. Once you right click on it, select "Properties" from the right click menu

    6. You will see three tabs across the top, select the middle one titled "compatibility"

    7. Go to the bottom of this tab and make sure that the box next to "run this program as an administrator" is checked in (filled in with a check mark)

    8. After you fill it in click apply and then okay to close the screen

    9. Now, go back to the icon in step 4, the sam and max installation icon, and double left click. The key to this is to have nothing else open and just wait, literally about one minute. During that time your CD drive should be spinning and hard drive working and your windows shell will slow down big time. IF YOU DO ANYTHING ELSE DURING THIS EXPLORER WILL CRASH so hands off! After about a minute or two a yellow windows "allow or deny" box will come up and when it does, select "allow". This should allow the game to install as it did for me.


    AND YOU THOUGHT YOU WERE DONE!

    well, MS and Telltale/adventure company have another surprise....THE SAME ERROR WHEN STARTING THE GAME AFTER ITS INTSALLLED ON YOUR HARD DRIVE! but never fear the same thing as above just has to be done 6 more times!


    1. Go to the place you installed the game (usually Program Files, The adventure Company, Sam and Max Season One

    2. Find the folder called "episode one culture shock" and double left click

    3. Find a file called SAMMAX 101 and right click

    4. Select Properties from the right click menu

    5. Select the second tab called "compatibility"

    6. Go to bottom and select " Run this program as administrator"

    7. Click apply and exit the screen. You should now be able to run THAT EXECUTABLE ONLY, ie for episode one. You have to make a new shortcut on your desktop to the file you just modified or it wont work (at least not for me).

    8. You have to do this for each episode. Bleh, but at least you get some Sam and Max goodness. The game should run at this point no problems.



    Commentary:

    Even with the "run as an administrator" option selected under vista the game is still requiring the "deny or allow" dialog box to pop up and Vista says "unknown publisher" which makes me wonder if the game was digitally signed? Rollercoaster tycoon three for example does not prompt me for this when I play it, but if I run a program like PC wizard that is attempting to query the kernel and the system for info, the allow or deny yellow box (not the UAC windows cancel or allow box like you get in control panel). I believe that this is a problem with the game being incorrectly signed/flagged by the publisher of this version as its triggering vista's security automatically at every step of the way.

    The registry error is not your typical "its a maybe bad program we should ask", it actually causes a technical error message to pop up that means nothing to probably 98% of windows users, which indicates that its a very abstract, not routinely handled exception that vista is flat out blocking behind the scenes, similar in the way that execute zero bit data protection works.
    Not sure what the deal is but seems like someone somewhere did not do much vista testing, or maybe this error is so small no one caught it during testing phase.


    Anyways, hope this helps and enjoy the game!

  • Thanks for the responses guys.

    Computer is just over a week old, I've checked for updates to the DVD driver and there are none. I've checked all the items listed under the IDE ATA/ATAPI controllers, there are 2x ATA channel 0, 2 x ATA channel 1, 2x Standard Dual Channel PCI IDE Controller. I cannot find any "advanced options" under any of these items or any mention of a transfer mode. As I can't access my DVD at all I don't have the option of being able to run the program out of autoplay. I'll try the event log option tomorrow, don't particularly feel like crashing my pc at the moment.

  • I just bought this last night at Best Buy and the same thing happens. I'm running Vista Home edition that came on the computer I just bought so I'm still learning my way around. Can't tell you the number, just that it's up to date.

    This has been known about since 08/2007 and there isn't an official fix? Man.

    Thanks for the workaround Brybir, that has at least worked for the install. I haven't applied it to the individual files.

    Seriously though, why is this broken thing still being sold in stores? Why isn't there an install patch by now? If there is, why isn't it linked to?

  • I just got my s1 bonus disc so I'll have it forever, thanks for the help :)

    I'd have never been able to figure out how to make it work...gah I hate Vista.

  • Ok, so I stumbled on a weird workaround.
    (Working on Vista Home Premium x64)

    - I inserted CD, got typical registry access errors.
    - Explored CD contents, double-clicked on setup.exe.
    - Windows Explorer proceeded to freeze up.
    - I manually ejected disc from my CD/DVD drive.
    - As soon as CD ejected the Vista security prompt appeared.
    - I re-inserted CD, and simultaneously click "Accept" on the security prompt.
    - The installation process started up.
    - Presto! Works like a charm!

    Hope that helps!

Add Comment