User Avatar Image

TWD: Unofficial workaround for instant "connection lost" issues

posted by DjNDB on - last edited - Viewed by 2.2K users

For those of you with the instant "Connection lost" error message after pressing "GET" i might have a simple workaround.

1. First, as usual, make a backup copy of:
Win7/Vista: %userprofile%\Documents\Telltale Games\The Walking Dead\

XP: %userprofile%\My Documents\Telltale Games\The Walking Dead\
(International users: Exchange "My Documents" for the translation into your language from here on)

Mac: ~/Library/Application Support/Telltale Games/TheWalkingDead/

2. Download and unzip the attached Empty_PatchFS.zip

3. Copy the contained WalkingDead101PatchFs.json and WalkingDead101PatchFs.updated.json into:

Win7/Vista: %userprofile%\Documents\Telltale Games\The Walking Dead\SyncFs\Meta

XP: %userprofile%\My Documents\Telltale Games\The Walking Dead\SyncFs\Meta

Mac: ~/Library/Application Support/Telltale Games/TheWalkingDead/SyncFs/Meta

and overwrite the files if they exist.

On Mac you have to write protect both files. On windows they already are.

4. Start the game and download episodes

5. Close the game

6. Delete WalkingDead101PatchFs.json and WalkingDead101PatchFs.updated.json from the Meta folder

7. Start the game and make sure the game still works as intended

Technical background:
This workaround temporarily disables the latest patches of the game, which broke the download for some people. That's why you have to undo it in the later steps, so you get updates again.

109 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Icy

    Thank you DjNDB!

    Worked for me too. I did however struggle a bit with the download, and it stopped at about 20% a couple of times, before it suddenly jumped up to the 60%-70% where it stopped again a couple of times before completing the installation. (Then again, internet is not always the best down in Ecuador, so that might be the reason for it stopping a few times.) So those who get the connection error during the download, keep going, it'll get there.

    Started ep4 now, and it seems to have done the trick.

    Thanks again.

  • User Avatar Image
    DjNDB Moderator

    @MarkoH01 said: DjNDB - you did (again) a great job. I am wondering however how your fix really works and why the download doesn't start without it....

    I added some background info about it in the first post.

    The instant "connection lost" issue came up with one of the latest patches. This workaround simply disables the patches for as long as you download the episodes.

    As far as i have heard it's not affecting everyone, and it sometimes works with multiple tries, so it might be a bit difficult to find out why exactly it happens in the actual source code.
    Without patches the downloader is not perfect either, as you may know from the previous issues, losing the connection at xx %, but in this case it seems to work better with the earlier download code.
    This also implies that they did change something on the download code, probably in order to fix some of the earlier issues.
    I believe there will be an official patch at some point, but i figured out this workaround so you guys can play as early as possible.

  • you sir get +10 thank you

  • You are amazing! Telltale, you guys should really consider this guy for a job!

    Klasse! Du bist mein Held!

  • @DjNDB

    I'm truly not trying to be patronizing but you are incredibly awesome and Telltale should hire you. Thanks mate it worked perfectly.

  • I spent the bulk of the morning trying this workaround, unfortunately to no avail.
    But I can't be angry with you for this turn of events, Its Telltale who seem to have dropped the ball here.

    I appreciate your generosity and willingness to share a possible solution!

    Keep up the good work.

  • Wow, thanks man... it worked for me, too. At first try... almost. Only while downloading episode 2, it lost connection at 80-something% and when i re-tried to download it re-started from 48% and when it got to 52-53% it "jumped" to 87% and finished without any other problem. The other two episodes downloaded smoothly. Slow, but at least until the end. Now I'm doing everything from the beginning because I uninstalled the game trying to download the 4th episode but it's no problem. Problem is that a solution came from a player of this game, an user of this forum, and not from the ones who CREATED AND DEVELOPED the game. Last time I give you my money, TellTale, that's for sure.

  • @DjNDB said: I added some background info about it in the first post.

    The instant "connection lost" issue came up with one of the latest patches. This workaround simply disables the patches for as long as you download the episodes.

    As far as i have heard it's not affecting everyone, and it sometimes works with multiple tries, so it might be a bit difficult to find out why exactly it happens in the actual source code.
    Without patches the downloader is not perfect either, as you may know from the previous issues, losing the connection at xx %, but in this case it seems to work better with the earlier download code.
    This also implies that they did change something on the download code, probably in order to fix some of the earlier issues.
    I believe there will be an official patch at some point, but i figured out this workaround so you guys can play as early as possible.

    Wow! THIS is what I call a real explanation (and what I would have expected from Telltale). Thank you very much and keep up the good work. It is great to know that there is someone who takes the problems here seriously. You really ARE a hero for TWD players and a saviour, too :)

  • Disappointed, because following all the suggested steps in this thread (both in the OP and to delete temp files) didn't work at all for me. Still get an instafail.

    Really wish Telltale would address this issue, as something like it crops up on every episode release.

  • Worked here, technical sensible.

    But still a shame, that users habe to help themselves. Everybody pais money for this....

This discussion has been closed.