User Avatar Image

More activation/key problems (ugh!)

posted by Roachineer on - last edited - Viewed by 312 users

I just bought and downloaded the entire first season of Sam & Max.

Everything was working fine on my Acer WinXP SP2. Not even Norton 360 gave me any trouble. Then I go to play episode 4 (X-Abe) and the Key/Activation Reminder acts like I'm a cheap bastard. So I go to click on "I've already purchased this" and the following prompt craps on me:

missing one or more tags
( OK )

Now, I know I can just e-mail for a new key, yadda, yadda, yadda. No biggie. But what troubles me is that all the episodes I've played/finished don't give me this problem, while the rest think I'm being cheap?

Other than the reminder/activation/key problem, everything else works fine. I think we've got a bug in the activation/reminder. Don't worry, I already tried disabling firewalls. Still no success. Not the issue. I clearly point blame at this reminder thingy/activation key.

4 Comments - Linear Discussion: Classic Style
  • The first thing to try, annoying as it might be, is to go to the Find My Order page and re-download the error-causing episode. That frequently fixes problems like the missing one or more tags error. If that doesn't work, write to and someone will help you very quickly.

  • Ok, so I uninstalled the episodes that weren't working and re-installed episode 4.

    Works fine. The Key retrieval works, Reminder gives LAUNCH GAME prompt. Nothing.


    I did NOT DL the episodes all over again (yikes!). I just went back to the download folder they created on desktop and re-installed.

    Nor did I ask for a new activation key... (although I did e-mail away for one, yipee! I wonder what else I can get for free in my cereal box?)

  • The missing tags error means that something wonky happened with the activation system during download and/or installation. We don't really understand all the things that cause it, because the activation system is a third-party software and not Telltale's software, but we do know by now that redownloading or even just reinstalling often fixes it. I'm glad that was the case for you, and sorry for the inconvenience. Hope you enjoy the game. :)

  • Yeah, I should really stop performing satanic rituals while installing new games. I think it's affecting my karma.

Add Comment