Menu
User Avatar Image

Jumpy sound for 5.1 system

posted by Guybrush Threepwood on - last edited - Viewed by 458 users

These are my speakers.

Sam & Max 201 worked fine on my two speaker setup, but when I got a new 5.1 speaker set up, things weren't as smooth.

When another sound is being played over the music (for example foot steps, speech, gun shot, etc) the rear two speakers start going jumpy, but resume playing the background music when the sound is over.

Sort of like this...

7xb2kg1.png
Here's a sound clip/movie I recorded to show what I mean: http://files-upload.com/files/681535/Untitled.WMV

Remember: this is only the two rear speakers. The other three work fine.

I'm sorry this doesn't really make any sense, its's due to my lack of ability to explain things well. :p

13 Comments - Linear Discussion: Classic Style
  • Hmm, soundcards aren't exactly my forte, but I'm going to take a stab in the dark and guess that your soundcard is trying to do extra 5.1 processing, which is causing it to freak out. The game itself certainly doesn't have surround sound, so theoretically all of the speakers should be playing the same thing.

    You may want to try updating your drivers and directX, but I imagine the solution will involve fiddling with your sound settings. Try turning off any sort of extra 3D sound processing and the like and see if that makes a difference.

  • [quote=Will;48292]Hmm, soundcards aren't exactly my forte, but I'm going to take a stab in the dark and guess that your soundcard is trying to do extra 5.1 processing, which is causing it to freak out. The game itself certainly doesn't have surround sound, so theoretically all of the speakers should be playing the same thing.

    You may want to try updating your drivers and directX, but I imagine the solution will involve fiddling with your sound settings. Try turning off any sort of extra 3D sound processing and the like and see if that makes a difference.[/quote]

    The game is channeling different sounds to different speakers. For example, the speech is coming out of the front middle speaker only (which is what happens when the game/movie/whatever runs in 5.1 or more)... so, yeah.

    I don't have any settings I can really fiddle with, except without screwing everything else up. I mean, I've got no enhancement features on or anything... directX is all updated (10) and so are all my drivers.

  • Hmm, well I just verified with Randy that we aren't doing any sort of channeling, so your computer is definitely splitting the sound. Go to your control panel, load up the Sounds and Audio Devices Properties, then click on Advanced down at the bottom next to speaker settings. Then in that new window, go to performance. Try turning off Hardware Acceleration and see if that makes a difference.

  • Sorry, but how do I do that on Vista?

  • Oh right! Vista! Umm... Gimme a minute to find a Vista machine and I'll tell you.

  • Alright, cheers.
    Sorry not to mention it before.

  • Ok, after doing some research, I've got some bad news for you. Microsoft, in their great and lofty wisdom, have decided to completely remove hardware acceleration from Vista. So the method I suggested is somewhat impossible. Basically, all of the audio decisions are made by your driver, and unless your soundcard has some sort of properties tool, I'm not sure how to adjust the settings at all.

    The only thing I can think of is to go to Control Panel/Sound/ click on your sound card in the menu and then click on the Configure button on the bottom. I assume you already did this when you were setting up your system, but it is worth mentioning nonetheless. You might be able to trick your system by telling it you have 2.1 channel, which might improve things for Sam & Max, but you would have to re-adjust your settings to use 5.1.

    In the meantime, hope for a driver update? I'll keep looking into it.

  • [quote=Will;48332]Ok, after doing some research, I've got some bad news for you. Microsoft, in their great and lofty wisdom, have decided to completely remove hardware acceleration from Vista. So the method I suggested is somewhat impossible. Basically, all of the audio decisions are made by your driver, and unless your soundcard has some sort of properties tool, I'm not sure how to adjust the settings at all.

    The only thing I can think of is to go to Control Panel/Sound/ click on your sound card in the menu and then click on the Configure button on the bottom. I assume you already did this when you were setting up your system, but it is worth mentioning nonetheless. You might be able to trick your system by telling it you have 2.1 channel, which might improve things for Sam & Max, but you would have to re-adjust your settings to use 5.1.

    In the meantime, hope for a driver update? I'll keep looking into it.[/quote]

    Before I forgot, for future episodes, is it possible to simply add something that forces 2.1? Or is that impossible...?

    Yeah, I did that when I set it up, but it's a bit of a bummer having to change it to 2.1 everytime I want to play Sam & Max -- if that's what you were suggesting.

    I'll hope for a driver update, but I never really get them for my sound card.

    Thanks for your help. :)

  • That decision's totally up to the driver, sorry :(

  • Yeah, like Doug said, I'm entirely sure what we could do about it, but I'll definitely bring it up. Maybe the programmers know some little trick that I don't.

Add Comment