User Avatar Image

Poker Night 2 locks up computer on startup

posted by GuruGuru214 on - last edited - Viewed by 851 users

As soon as I hit the button to launch Poker Night 2 in Steam, my screen goes completely black and my computer becomes completely unresponsive, including toggling Num Lock, and I have to force restart it. Any help would be greatly appreciated.

18 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator

    Description: Realtek HD Audio output
    Date and Size: 7/16/2007 18:48:54, 4403712 bytes

    There's a chance that the problem is caused by the old Audio driver.
    You can try installing the latest Realtek HDA Driver.

  • Two restarts later, nothing's changed but the driver.

  • User Avatar Image
    DjNDB Moderator

    And the entire computer still crashes?

    Have you already tried unplugging all non essential USB devices?

    Running the game during a clean boot is also worth a try.

    Booting clean in Windows XP:
    1. Click Start --> Run --> Type msconfig --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Process SYSTEM.INI file
    4. Uncheck Process WIN.INI file
    5. Uncheck Load Startup Items
    6. Click on the Services tab
    7. At the bottom, check Hide All Microsoft Services
    8. Click Disable All
    9. If running the game on Steam, re-check the "Steam Client Service"
    10. Click OK
    11. Click Restart
    12. After reboot, run the game to see if it works.

    After performing the necessary steps, restore your settings by doing the following:

    1. Click Start --> Run --> Type msconfig--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click OK
    4. Click YES, when asked to restart your computer

  • Unplugged everything, did a clean boot, no change.

  • User Avatar Image
    DjNDB Moderator

    That's a very unusual crash. Normally the game wouldn't crash the entire computer in case of an error.
    Does the computer run stable with other games or applications?


    I attached a zipped prefs.prop with low graphics settings. You can try if putting that into
    %USERPROFILE%\Documents\Telltale Games\Poker Night 2
    helps.

    You can also try running the games .exe as admin or in different compatibility modes.

  • Yeah, I've never had an issue like this before. There's one other game that I think used to bluescreen me sometimes (the original Bioshock, maybe?) because it didn't like my graphics card, but most everything else runs stable for me. I've never had a game that just gives me a black screen and freezes the whole computer there.

  • Yep, that did it. Instead of a black screen and a freeze, I got Poker Night 2 in a small window. I'll play with it a bit and see if I have any issues with going to fullscreen or something. Thanks for the help!

  • User Avatar Image
    DjNDB Moderator

    That's great. If pushing up the graphics settings crashes it again, we can assume that it's graphics card or graphics driver related.

  • I bumped it to fullscreen with no problems, other than a bit of slowing. I bumped the rendering to high and it got quite a bit slower but stayed stable. I bumped it back to low and exited, and I was able to launch the game in fullscreen without a problem. The only setting I didn't try bumping up was anti-aliasing.

  • User Avatar Image
    DjNDB Moderator

    @GuruGuru214 said: The only setting I didn't try bumping up was anti-aliasing.

    It would be interesting to see if that makes it crash again. Then we would know what caused the problem.
    You can always replace the prefs.prop afterwards.

Add Comment