Menu
User Avatar Image

Sam and Max - Could not initialize Direct3D

posted by Andy Pro on - last edited - Viewed by 2.8K users

Hi,

Just got a new computer, and now getting the above error when trying to run Sam and Max (ep. 203 to be specific).

I have looked over earlier threads, and posting a dxdiag file seems to be required, so I have done so.

Any help much appreciated.

Cheers,

Andy

5 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator

    Please run the DirectX updater.

    Card name: Intel(R) HD Graphics 4600

    Name: NVIDIA GeForce GTX 660

    This looks problematic. You have integrated Intel graphics and an Nvidia card that isn't used. Either switch it to use the Nvidia graphics for the game (if that's possible), or deactivate the integrated Intel graphics altogether.

  • @DjNDB said: Please run the DirectX updater.

    This looks problematic. You have integrated Intel graphics and an Nvidia card that isn't used. Either switch it to use the Nvidia graphics for the game (if that's possible), or deactivate the integrated Intel graphics altogether.

    Thank you for your quick reply. I ran the DirectX updater, and all was up to date.

    Unfortunately the rest goes a bit over my head! I am unfamiliar with the integrated graphics, so now I am confused as to what my computer is now doing with regard to graphics. Am I not running my Nvidia card?

    And to deactivate integrated graphics, would I do that in device manager, under the driver tab, where it has the option of disabling the device?

    Thanks again,

    Andy

  • User Avatar Image
    DjNDB Moderator

    Currently you are running on integrated graphics, and your nvidia card is unused.

    It looks like it should be a simple matter of plugging the HDMI cable into the graphics card instead of the Mainboard.

    If that doesn't work there's a BIOS setting. Please read your Mainboard Manual for details.
    Page 32-33 explain how to enter and navigate the BIOS.
    Page 51 has the relevant settings.
    - "Init Display First" should be set to PCIEX16
    - "Internal Graphics" should be disabled
    And of course the cable has to be in the graphics card then, or otherwise you won't see anything anymore.
    If you are not familiar with the BIOS, be very careful not to change any other settings.

  • Thank you, hopefully it's the first option.

    I'm not familiar with BIOS, so would rather not touch it.

    However, it is good to know I'm not using my graphics card! I need to sort this out to make sure it's not sitting there doing nothing...

    I'll have a look and let you know.

    Cheers

  • All is well now with Sam and Max.

    I selected my graphics card in the Nvidia control panel, and it worked.

    Cheers for your quick support, very much appreciated!

    Andy

Add Comment