User Avatar Image

TWD don't run on Mavericks Mac

posted by benjamin74380 on - Viewed by 7.3K users

First i am sorry for the bad english because i'm a french guy :) Hi So i download the new Mac OS Mavericks on my Macbook and The Walking Dead don't run. It's really strange because when i played before Mavericks the game works perfectly ...

So any people have the same thing on his Mac or anyone know how I can play?

Thanx you Benjamin74380

34 Comments
  • I just found out The Wolf Amongst Us won't run under Mavericks either. Something about an unknown developer. Surely there must be a way to get round this security.

  • I just tried Walking Dead and it won't run anymore either. It seems The Walking Dead will not play under OS X Mavericks. That sucks... I get an error screen right away, it won't even load.

    The Wolf Among Us was a Gatekeeper issue though. I disabled the security and it started and played just fine. This fix won't work for TWD though.

  • I have just sent this e-mail to support@.

    Hi there,

    I would like to report that The Walking Dead does not run on Mac OS 10.9 Mavericks. It crashed instantly.

    I've recently bought TWD and I thoroughly enjoyed season 1. I wanted to continue season 2, but since my upgrade to 10.9, that's a no go.

    I've read some disturbing things on the support forum, things like: "It doesn’t run on Mavericks. Though luck to you." I'm really fond of Telltale and I've bought lots of your games, and have never been disappointed. If TWD will never run on Mavericks, I will be gutted.

    My hopes are one of two things will happen:

    A) you will realise that, since the upgrade to Mavericks is free and easy, loads of Mac users will upgrade, and you will be flooded with unhappy customers. You will fix this issue. You will make me happy again. I mean: I've just cut of someone's leg with an axe after several tries, I can't just leave it there.

    B) you will reimburse me if A is not an option. I'll donate the money to the Red Cross if you do. I don't care about the money, I care about the game. This solution is not a solution anyways, please reread A.

    My admiration for Telltale has taken a blow. Please fix this issue.

    Mac users who upgraded are like the walking dead. One, two, even five, you can handle. But more are coming. Watch your six.

    Sincerely,

    My Name

    "Something coming back from the dead was almost always bad news. Movies taught me that. For every one Jesus you get a million zombies."

  • I was the same! Before updating my mac the game worked perfectly. I can still open up the game, but the color and quality severely diminished.

    I honestly would not have bothered upgrading to Maverick if I knew this would happen...

  • Wow, I wish I had known this would happen before updating.. You're right neither game will start for me.

  • Actually, it's working fine on steam for me now. Not sure what was going on earlier.

  • not working for me either, i just updated last night and bought TWD today to find it doesn't work... not happy at all

    • This bothers me a great deal. I somehow understand that TWD does not (yet) run on Mavericks. I'm expecting an update, though.

      But as a Mac user you're still able to buy TWD, but Telltale neglects to mention that it doesn't work on Mavericks. This is totally wrong. It's the very, very least they could do.

      I was almost tempted to check the "This comment contains spoilers" checkbox, because Telltale really spoiled my weekend with this.

  • I've sent the following e-mail to Apple blogger John Gruber (Daring Fireball):

    Hi John,

    Lemme get this out of the way: I'm a huge fan of DF. Nice job.

    I've discovered a major downside to free and easy OS upgrades: unsupported software. I've recently bought "The Walking Dead" from Telltale Games. A few days ago, I've upgraded to Mavericks (free and easy) and now The Walking Dead does not work anymore.

    I somehow understand that. The game was released in its entirety before Mavericks was in the picture. But you're still able to download and buy the game without any warning. Maybe it's time they changed the term 'Minimum System Requirements' to 'Minimum and Maximum…'

    Support from Telltale is woeful. Basically it’s "tough shit, we only support up 'till 10.8". But I'm reading and hearing buyers who found out their OS isn't supported after they bought the game.

    Are you hearing similar things? Vendors neglecting to provide an update for software, despite users massively adopting the new OS? I've demanded a refund, but they do not respond to my email.

    Anyway: I think a lot of vendors, especially game studios, will be in trouble lest they make sure Mavericks users do not buy their outdated software.

    Sincerely,

    My Name my_name@gmail.com

  • Sent an email directly to support a week ago.

    No response.

    Not holding out much hope.

  • They've lost me as a customer until this is fixed.

    Shame, was a great game.

    Guess I can still follow season 2 story on you tube.

Add Comment