User Avatar Image

Walking Dead Direct3D error

posted by HunterHyena on - Viewed by 1K users

"Could Not initialize Direct3d. Make sure you have current video drivers and close any other applications that might be running. You will need a video card that supports at least pixel shader version 1.2"

I click okay then this pops up

"Unfortunately, this error cannot be recovered."

I try every fix. The only one to work was Making it Windows 98, but that caused audio glitches and bad stuttering anytime I did an action, such as kick the window out of the police car. I can run Max Payne 3 on Ultra but this game refuses to start, unless I go to run it in a buggy state using windows 98. What makes it even more confusing is it worked flawlessly a few months back, and I played most of Episode 1 then came back and now this is happening.

8 Comments
  • User Avatar Image
    TelltaleMike Telltale Staff

    I apologize for the inconvenience. If you are receiving a Direct3d and/or pixel shader error, please make sure that you have downloaded the latest version of Direct X in order to run our game successfully.

    • I have downloaded the latest version, reinstalled the game, and verified the game's cache on Steam and am still getting the same issue.

      • User Avatar Image
        TelltaleMike Telltale Staff

        Please read this FAQ on how to run our Support Tool, and follow the steps to run the tool, and reply to this email with the download link copied and pasted into this reply. You can find the FAQ here:

        http://www.telltalegames.com/community/discussion/44150/twd-support-tool-for-information-gathering

        I apologize for the inconvenience you are experiencing, after receiving the information from your support tool, we will be able to assist you further.

        Thank you, Mike

          • User Avatar Image
            TelltaleMike Telltale Staff

            After looking over your support tool data, I have a few possible solutions:

            1) Ensure you have the latest drivers for both your graphics card, and update your computer's BIOS

            2) Restart your system

            3) Unplug your gamepad (and all other USB devices other than keyboard/mouse)

            4) Verify your cache if you purchased through Steam (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335)

            5) Run the game as admin

            6) Run the game in compatibility mode (We recommend Windows 98/ME)

            7) Reinstall the game (c)

            8) Make sure that the Steam application is not set to a compatibility mode (right click on steam and click properties, then check compatibility, and make sure that it is not checked to play in a different OS)

            • I have done all of the above, and the only one that half worked was running it in Windows 98/Windows Me. However, when I did that the game would stutter whenever an action would be performed or whenever a line of dialogue was spoken. Other issues stemming from that would be massive lag between game options and the game's response to them. For example, when your character yells "Look out" to alert the cop driving the car at the beginning of the zombie in the rode, the option popped up a good 20 seconds before the zombie was seen.

              I have gone through each type of compatibility that I can between Steam and Walking Dead and none of them seem to make a difference.

              • User Avatar Image
                DjNDB Moderator

                Card name: NVIDIA GeForce GTX 550 Ti
                Current Mode: 1024 x 768 (16 bit) (60Hz)

                This caused the "Could Not initialize Direct3D" error message initially. You need to set the display color depth to 32 bit.

                Then check the properties of the Steam.exe, and the games .exe files, and disable any compatibility mode and "run as admin" settings.
                Sometimes compatibility mode is checked, but is grayed out. Then you have to click on "Change settings for all users" at the bottom to disable the checkbox.
                Afterwards try if the game works.

                If the method mentioned above didn't work, you can try disabling it in the registry. Then restart the computer and try running the game again.

Add Comment