User Avatar Image

Strong Badia the Freeze

posted by RumbleRed on - last edited - Viewed by 174 users

I like these games, but the freezing in the Wii versions is ridiculously common.

The first game froze on me the first time I went into the photo booth, and I had to load my file and redo some things. Then later my save file got into a state where the game would crash when I saved. And eventually one of those attempts to save deleted my Homestar Ruiner file when it crashed and I reset. I had to redo the whole game.

And now Strong Badia the Free. Sometimes certain animations don't play right. I've seen fire frozen on a single frame and I've seen the image of the map missing from the narration sequence after taking over a country. And my extended play file always freezes when I save, which means I can't go to Bleak House because it autosaves when I do. And my brother just finished the game, but it froze just before the credit sequence. This is getting very annoying.

Come on, Telltale, fix your bugs! Release updates! Until you do, I'm severely discouraged from buying any more games in the series. And I'm sure there are plenty of people like me.

2 Comments - Linear Discussion: Classic Style
  • Freezes on the Wii version have been reported by some people, but we have so far not been able to isolate most of them. These freezes didn't come up during our own testing (or Nintendo's) so figuring out what is causing them for the subset of users experiencing them can be tricky! I know that's not much consolation if you're one of the people having the problem, but this is an issue that we have been working diligently on, and the fact that we have not released an update for the game doesn't mean we're ignoring it.

    You might try deleting Strong Badia the Free and redownloading. Some users who had freezing problems told us that doing this fixed the problem for them. If that doesn't work and you find that the game is just unplayable, send an email to explaining the problem and we can hook you up with the PC version.

  • I tried redownloading, and it didn't help. I'd bet it was a coincidence that people have solved the problem that way, because I've seen at least one instance where the freezing went away on its own after a few tries. But my current extended play file is always freezing.

    I believe the problem is triggered by something in the saved data, since I can have two files at the same point in the game and only one of them crashes when I load it, then save. Have any Telltale people looked at save files from people experiencing this issue? I can supply mine if it would help.

Add Comment