User Avatar Image

DLL crash

posted by ZiglioNZ on - last edited - Viewed by 253 users

Hi,

the demo crashes for me whenever I try to enter the Esc menu during gameplay and during the animation after the first room.

Windows reports this Error signature:
AppName: wallacegromitdemo.exe
AppVer: 2009.3.12.21508
ModName: d3d9.dll
ModVer: 5.3.2600.5512
Offset: 000f7e7a

Now, I think this problem might be related to the graphics driver I currently use: the Intel Embedded Device Drivers. I think their support for D3D is not fully functional.

Also, in the first room the salt jar is invisible, I wonder if it's due to a mishandling of 3D objects.
Anyway, has anyone experienced the same problems?
Do you know if I can disable hardware acceleration for D3D?

Thanks,
ZiglioNZ

Here's a file that goes with it
<?xml version="1.0" encoding="UTF-16"?>











11 Comments - Linear Discussion: Classic Style
  • Hey Zig, it's almost certainly related to your graphics card and drivers. If you can find new drivers, I would highly suggest updating. Besides that, try lowering your graphics quality to 1.

  • Hi Will,

    now that I had an excuse, I've upgraded to the latest version of the Intel Embedded Device Drivers that still support my old Centrino 855 (ver 8.0).

    I've noticed an improvement in performance, animations run much smoother than with the other drivers (version 6).
    But Wallace&Gromit Demo still crashes with the exact same error at the same point: during the animation following the first room, while the sky changes colour.

    I've run the Direct 3D tests provided by Dxdiag and these drivers pass all the D3D and DirectDraw tests for DirectX API 7, 8 and 9.

    I hope if that's a bug, it gets fixed before the first episode of the season I've ordered is published.
    Otherwise I'll have to buy a new laptop... but who wants Vista?!

  • Well another thing you can try is completely redownloading the game from scratch, in case you have a damaged file. You can also try updating your soundcard drivers.

  • Update. I've installed the first episode.
    Initially it just crashed, just after the beautiful introduction.
    But then I started the tutorial and it didn't crash! I managed to play all the way to after serving breakfast.
    Am not too sure why that worked. I've lowered the resolution to 800x600.
    Maybe that saves a bit of memory that was required.
    I hope I've solved my problems, anyway, I love this game!!
    It makes me feel like it's 1990 again (in a good lucas-fan sense)

  • Hi everyone,

    the game crashes before letting me do anything unless I play this sequence:
    preview - tutorial - first scene.
    Just then it lets me load saved games.

    Very strange.

  • @ZiglioNZ said: Do you know if I can disable hardware acceleration for D3D?


    That should be possible via DxDiag.
    Start | Run | dxdiag | OK
    On the third register [should be “Screen” or something similar; I don’t have an English Windows/DX] you can click a button, that says exactly that. [Not sure with Vista, anyway.]

    Did you upgrade DX to the latest version, i.e. November 2008?

  • Technically, the latest version is March 2009. They just don't make the updates obvious.

  • MS managed to release a new version? Good to know.
    [Though it’s ridiculous that the DX installer gets a new version number with each release, but DX itself not... -_-]

  • User Avatar Image
    Cal

    I was getting a DLL crash on launch. After setting the desktop resolution down too 800x600 it now works, hurrah! (hope that helps any others with probs)

  • Hi guys,

    seriously there must been some bugs in the sw because I've so far managed to play the game up to past making the fertilizer.
    I should be able to complete it even on my legacy centrino gme855, with 720megs of Ram, win XP and 1.8ghz only of cpu speed.

    But occasionally the game crashes and, when I load it, it doesn't let me start or load any saved games unless I play all the time preview - tutorial.

Add Comment