User Avatar Image

The Monkey Island Demo goes reeeaaaalllyyyy slow...

posted by GinnyN on - last edited - Viewed by 268 users

First, I have to admit I don't have the complete recomended hardware, but the only thing I lacked is the 2.0 Ghz for my processor (I do have 1.6 Ghz Intel Core Duo) and Sam and Max, Strong Bad, and Wallace and Gromit runs pretty well (Even the episode of Sam and Max Second Season (Yep, I only played Ice Station Santa :P) runs smoothly with the High Graphics) but, with the Monkey Island Demo (I have no idea if with the complete episode too), there's a bit of retard with the movement of the mouse and the cursor (Everything in the game itself looks like they lack frames of movement as well). I tried with the Graphics at minimum, and with the resolution at minimum (I even updated the Graphic Card Driver!) and still, there's a "lag" with the mouse and the cursor (I really don't care about the graphics, the mouse/cursor response problem is bugging me). Anybody knows why?

Thanks in advance T_T

5 Comments - Linear Discussion: Classic Style
  • Sadly, you're probably like me.

    Doomed to have to get a new computer.

    And it really makes me sad because I thought point and click adventure games were the last vestige of new games I could play without getting a new computer and just using this old 03 laptop..sigh.

  • The weird part is, when I put the graphic quality to 3, the menu runs smoothly, but, in the game itself, still run slow. I'm not going to say is un-playable, but still bugs. I wanna know why this is happening before buy the game in any form...

  • That's the processor speed at work I'm afraid. You can try running in fullscreen mode to help reduce the lag. Another thing you can do is to turn off as many background programs as humanly possible. If you want to be really thorough about it, you can even do a clean boot:

    To Boot Clean in Windows XP

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Process SYSTEM.INI file
    4. Uncheck Process WIN.INI file
    5. Uncheck Load Startup Items
    6. Click on the Services tab
    7. At the bottom, check Hide All Microsoft Services
    8. Uncheck all boxes in the window or click the button labeled Disable All
    6. Click OK
    7. Click Restart
    8. After reboot, run game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click OK
    4. Click YES, when asked to restart your computer

  • I can't believe how many junk I was running background...

    Well... runs better now, but I'm not saying great :P

    Still, really playable and funny. The day the games becomes un-playable and/or un-funny, I think I'll upgrade.

    Thanks a ton for the response! ^^! You're really the best!

  • Yeah, you can actually go through and just leave most of that junk off. There's no need for most of it to start up when you first boot your computer. At home I have my firewall and virus scanner boot at startup. Everything else I leave off.

Add Comment