User Avatar Image

TOMI: menu screens are fine, game is laggy

posted by anglerush on - last edited - Viewed by 853 users

I'm not sure what the problem is. I have the game set to the lowest quality, and the menu screens are running perfectly fine, but when the game starts, the framerate drops to about five to nine frames per second.

I've shut down all other programs while playing, that hasn't helped. I've uninstalled and reinstalled it. That hasn't helped.

The Sam and Max games worked fine for me. So have SBCG4AP and the first two parts of W&G.

Muzzled gave me the exact same problem when I was playing it. It would go from fine to laggy and back to fine. I just downloaded it again an hour ago, and now it's running smoothly.

Can someone tell me what's going on?

23 Comments - Linear Discussion: Classic Style
  • @Novotnus said: and doing your msconfig trick the game was... well, on lowest settings it was playable. Just a little laggy durign the intro puzzle and in the town, but I was able to finish it (which I'm proud of).
    Thanks again.

    Wait...what msconfig trick?

  • the msconfig trick is the Clean Boot I occasionally recommend. To Boot Clean in Windows Vista

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Load Startup Items
    4. Select the Services tab
    5. Check Hide all Microsoft services
    6. Click Disable all
    7. Click on OK
    8. Click Restart.
    9. After reboot, run game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click Ok
    4. Click Yes, when asked to restart your computer

  • @Will said: the msconfig trick is the Clean Boot I occasionally recommend. To Boot Clean in Windows Vista

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Load Startup Items
    4. Select the Services tab
    5. Check Hide all Microsoft services
    6. Click Disable all
    7. Click on OK
    8. Click Restart.
    9. After reboot, run game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click Ok
    4. Click Yes, when asked to restart your computer

    Great! It's working now. Thanks!

  • @anglerush said: And I don't know how to check my video card XP

    Go to Run and write dxdiag. Then, check the Display tab.

    @anglerush said: Is there anyway to update my lappy's processor?

    EDIT: Just found out how expensive that would be. I'll just stick with my earlier plan of upgrading my desktop.

    Where did you find that?

  • Hi,
    I've only just got round to installing and playing TOMI. Very disappointed that I'm having a similar lagging problems with the game. The Animation is very jerky. Could be that my processor isn't powerful enough but my display diagnostics are:

    Name: NVIDIA GeForce 6100
    Current Display Mode: 1280 x 720 (32 bit) (60Hz)
    Main Driver: nv4_disp.dll
    version: 6.14.0011.7813 (English)
    Date: 18/09/2008 00:55:00
    Running on Microsoft Windows XP Professional Service Pack 3

    I don't know whether it's the fact that it's 1.81 GHz that might be causing the problem but any help would be much appreciated.

    Cheers

    Danimate

  • Hey Danimate,

    It does seem likely that the processor would be holding you back. I'd say your best bet is to try turning off as many background programs as possible before playing the game, and then turning your graphics settings down a bit. The clean booting thing mentioned above would also probably help you greatly.

  • @GinnyN said: Go to Run and write dxdiag. Then, check the Display tab.

    Where did you find that?


    I called geeksquad. :)

  • Cheers Will.

    I will look to improve my processor and sort out my background programs. Got far too much on my desktop.
    I can actually play it properly without any problems, just had to reduce the quality a fair amount. Still brilliant quality though, doesn't take anything away from the game. :o

    Cheers

    Danimate

  • I have tried the MSConfig boot. Didn't make any difference on the full quality so I definitely will assume it's a processor issue and will hopefully look to improve it. Just thankful I can still play the game which I'm enjoying. :D

    Cheers

    Danimate

Add Comment