User Avatar Image

Situation Comedy is almost unplayable due to jerky graphics

posted by oddbasket on - last edited - Viewed by 1.5K users

I need help. I downloaded SC through the link received by email. The graphics are extremely jerky and stutters like 5 frames per second. The scripted animations plays fine at full framerate though. but actual gameplay drops to stutters.

My system is a HT P4 3ghz, GF7800GS 256mb, Audigy2, 1gb ram. Tried lowest possible settings and its still the same. Culture shock plays just fine though.

Also, I would like to see support for 1280x1024 resolution. My LCD soesn't scale anything other than the resolutions it supports (setting to scale by adapter doesn't help) so a custom 1280x960 just adds graphical garbage at the bottom and it really ruins gameplay.

But my above problem is of upmost importance, pointless to have the correct resolution when I can't even play the game properly, eh? Would appreciate any remedies, thanks.

52 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Kevin Telltale Staff

    Please try deleting your prefs.prop file

  • I have exactly the same problem with oddbasket.
    I've tried to delete the .prop file, but nothing changed...
    My system is:
    Pentium 4 HT 2.8Ghz, 1.5GB Ram, ATI Radeon X1950Pro.
    I have already installed the most recent drivers for all my devices.

  • @Kevin said: Please try deleting your prefs.prop file


    Nope, doesn't help. Neither does redownloading and reinstalling. Hope you can come up a another solution. It's almost as if the game was badly coded this time round or heavily unoptimized.

  • @mandilarator said: I have exactly the same problem with oddbasket.
    I've tried to delete the .prop file, but nothing changed...
    My system is:
    Pentium 4 HT 2.8Ghz, 1.5GB Ram, ATI Radeon X1950Pro.
    I have already installed the most recent drivers for all my devices.

    I have the same problem. When the jerky graphics happens, my harddisk appears to be trashing as well. Doesn't happen with episode 1 though.

  • And I've tried everything, drivers and directx are the latest, every ingame setting, even lowering and disabling hardware acceleration for both display and sound. Nothing works. And it seems this happens across different hardware configurations.

    It happens/worsens when something other than Sam moves on screen ie Max or the little SkinBodies car. Definitely looks like a game/programming issue. I think this warrants immediate attention by tech support.

  • I also have the same issue with SC. The first episode work just fine, no problems at all. This one stutters like crazy... the mouse pointer takes big leaps instead of smooth motion. Seems worse when there's onscreen animation - for instance, in the office at the beginning, there's improvement when Max doesn't move around.
    System: AMD AthlonXP 2400+ on Asus A7V600-X motherboard, nVidia 7600GS with 93.81 drivers, onboard SoundMAX digital audio via S/PDIF, 1GB RAM, tons of disk space.

  • At least its not just me. That was my first complaint, and I figured at the time it was an old graphics card. Guess not.

  • I've been having the same problem, but I have integrated video as well. The main street, especially with the skinbody car, has the most slowdown.

  • No I'm not saying this just to be awkward , but it played just fine on my, rather lowly, system (AMD 2800+, 512MB RAM, 80GB HDD, X800 256MB). No stuttering, no slowdown - perfectly smooth.

    Obviously, I cannot assist with anyone's problem, but at least you all know now that it isn't the game.

    Sarah

  • @Larrin said: I've been having the same problem, but I have integrated video as well. The main street, especially with the skinbody car, has the most slowdown.

    In your case, it's definitely because of the integrated video, which is not supported. Sorry about that. :(

    For the rest of you - are any of you running programs that could be carrying on in the background and interfering with the game? What type of virus protection are you using?

Add Comment