User Avatar Image

Sam & Max Games and Vista - crash with error message

posted by mat79 on - last edited - Viewed by 846 users

I've just installed Sam'n'max ep 3 under Vista, and all i get is this error in the eventlog when i start it:
Fehlerhafte Anwendung Sam and Max - The Mole, The Mob and the Meatball.exe, Version 0.0.0.0, Zeitstempel 0x45c3f479, fehlerhaftes Modul unknown, Version 0.0.0.0, Zeitstempel 0x00000000, Ausnahmecode 0xc0000096, Fehleroffset 0x001734d9, Prozess-ID 0xe14, Anwendungsstartzeit 01c74c183c3d34de.

Even running as Administrator didnt help.
System: Vista Business 32Bit, Geforce 6600GT, 1024MB RAM

13 Comments - Linear Discussion: Classic Style
  • Thank you for posting about this. That sounds to me like one of those generic Windows messages that are oh so helpful. :p

    We haven't experienced any problems like this so far, but we'll keep an eye out for it.

  • Mat - I just moved your posts about this error into this thread, so we can keep them all together.

    Monger - are you German also? Makes me wonder if this is specific to the German version of Vista, or maybe it's just a coincidence...

  • i've found the reason for my error!

    disable DAP (the hardware NX support) for Sam'n'max and it works!

    (for some reason DAP and Sam'n'Max worked fine on XP, but not on Vista)

    Edit: tested with Ep2 and 3... seams to work fine now

  • @mat79 said: i've found the reason for my error!

    disable DAP (the hardware NX support) for Sam'n'max and it works!

    (for some reason DAP and Sam'n'Max worked fine on XP, but not on Vista)

    Edit: tested with Ep2 and 3... seams to work fine now

    Yay, it works for me, too! :D Thank you!

    Btw. this fixed also an issue with 1701 A.D. , which crashed in the same way when the copy protection went checking the disc. And it seems to me that Sam & Max crashed at the same moment, when they should get activated.

    Seems like DAP successfully blocks all copy protection systems! ;)

    Edit: just for info: for some reason, the Sam & Max games created a new "Desktop" Folder and inserted their links in there, instead of copying them into the real desktop folder. I guess that the setup relies on a static path for the desktop that just doesn't exist in Vista anymore.

    It's really just a minor glitch, but maybe you can mention this to the setup team for further releases.

  • Thank you for the information. I'm really glad it was such a simple fix!

    Excuse my ignorance, but what is DAP?

  • @Emily said: Thank you for the information. I'm really glad it was such a simple fix!

    Excuse my ignorance, but what is DAP?

    Erm... In english it is called DEP (Data execution prevention). Two Minutes ago I only knew the german word, and assumed that mat79 knew the right translation. :o

    And as you most probably know, DEP shall prevent buffer overflow attacks by seperating code execution memory from data storage memory, and is only enabled by default for all microsoft products. Unfortunately, really a lot of 3rd party software crashes when DEP is enabled, although it really sounds like a great idea...

  • I am having the Episode 3 slow down performance problem you all are having. I have. Episode 1 & 2 ran super smooth, and Episode 3 does not.

    How do I disable DEP? It seems to me that this is a 64bit OS thing. I am using Windows XP64 Pro. All I understand of DEP is that it works in a 64 bit environment.


    System:
    AMD 64 3500+ (939 winchester)
    2 Gigs RAM (corsair value)
    BFG GeForce 6800 Ultra
    Running Windows XP 64 Pro

  • @Roft said:
    How do I disable DEP? It seems to me that this is a 64bit OS thing. I am using Windows XP64 Pro. All I understand of DEP is that it works in a 64 bit environment.


    It is absolutely not a 64Bit exklusive thing, and as I saw yesterday, I also have the performance problem. So probably this won't help you at all.

    To deactivate DEP, go to:

    Control Panel -> System -> Advanced (or extended, don't remember the translation) -> Performance -> Settings -> Data execution prevention -> set to "activate DEP only for windows programs and related services".

  • yep, meant DEP, not DAP.

    Control Panel -> System -> Advanced (or extended, don't remember the translation) -> Performance -> Settings -> Data execution prevention -> set to "activate DEP only for windows programs and related services".

    better solution: leave it enabled, and only disable it for the apps that have issues with it.

Add Comment