User Avatar Image

W&G graphical glitches

posted by werehare on - last edited - Viewed by 189 users

I've seen a few threads about graphical problems but none exactly like this (and actually, none which seem to have had any resolution) --EDIT Of course, after posting I see the fairly obvious and very similar thread... here *rolls eyes* --but I just now decided to go crazy and grab all the W&G games and it's looking like I made a huge mistake. It looks like this:
(Screen shots from the menu and tutorial).

wallaceAndGromitBroken.jpg

I've updated to the latest graphics drivers.
I've updated directX.
I've tried changing screen resolution, detail and hopping from windowed to full screen.

Has anyone else seen this? (And hopefully then progressed to a point where they can play the game?)

FYI: My machine isn't the newest kid on the block (single processor 2.66Ghz). I have a Radion X850 graphics card. But it's been enough to play seasons 1 and 2 of Sam & Max with only a bit of slowdown. Tales of Monkey Island was more klunky but still didn't have any graphical bugs like this...

Have I officially just fallen off the bottom of the PC performance bell curve?

Any help would be greatly appreciated. Thank you.

8 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator

    Moved to game support.

    You really tried a lot already.
    Please post a dxdiag log.

    dxdiag
    Windows XP: Go to your start menu and click on run. Type in "dxdiag" and hit enter
    Windows Vista / 7: Press the windows key on your keyboard or click on the start menu. Type in "dxdiag" and hit enter.

    Now click on the button that says "save all information".
    It will prompt you to save a file. Save it where you can find it.

    Then zip the file and attach it to a message.

  • Well, here is the dxdiag file. I tried having a look through it myself but I have no idea what I'm looking for and got lost in there pretty quick!

    Sorry for posting in the wrong place btw and thanks for shifting the thread.

  • See this thread. Maybe it will help.

    http://www.telltalegames.com/forums/showthread.php?t=8101

    I had the same problem, but I manually set my resolution up higher and higher until I found one that worked. The lower resolutions had video glitches and discolorations in them on my video card. I hope either of these help.

  • User Avatar Image
    DjNDB Moderator

    It is a problem with some older graphics cards.

    I'm not sure if there is a definite solution, so we can only try some obscure stuff.
    Does the second Episode look normal?
    You have tried various graphics settings, but did you try the lowest detail level possible?

    Run the DirectX updater and
    update your Sound Driver.
    If you don't use it also disable your onboard sound (SoundMAX Digital Audio) just to be sure that 8 year old driver doesn't cause trouble.


    Also a clean boot couldn't hurt, just to be sure.

    Booting clean in Windows XP:
    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Process SYSTEM.INI file
    4. Uncheck Process WIN.INI file
    5. Uncheck Load Startup Items
    6. Click on the Services tab
    7. At the bottom, check Hide All Microsoft Services
    8. Uncheck all boxes in the window or click the button labeled Disable All
    6. Click OK
    7. Click Restart
    8. After reboot, run the game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click OK
    4. Click YES, when asked to restart your computer

    Based on Will's post

  • Well...
    DirectX is updated.
    Sound driver completely updated
    Disabled onboard sound card.
    Did the clean boot thing.
    Tried the lowest and hightest resolution and details settings (and variations).
    But no joy.
    (Now I remember why I bought a console! :rolleyes:)

    If I keep flipping in and out of resolutions then every now and again it'll flip into something which looks correct, but as soon as you do something else (change menus or start a game, it returns to it's previous state.)

    I also tried running the second episode and it's the same deal.

    Anyways. I'm going to assume at the moment that my current PC isn't supported. I'll just have to wait until I can afford a new PC before I get to play. Anyways, thank you very much for the help.

  • User Avatar Image
    DjNDB Moderator

    @werehare said: Anyways. I'm going to assume at the moment that my current PC isn't supported. I'll just have to wait until I can afford a new PC before I get to play. Anyways, thank you very much for the help.

    There are still some decent AGP cards available, in case you are looking for a cheap update.

    There's one more thing you could try through.
    You could try older Driver Versions. If you find one that works you can try to track down the newest one that still words. It might not be ideal, but it could get you through the game.

    Fully uninstall the current drivers first though.

  • Thanks for the extra suggestions but all this updating and tweaking has just solidified my resolve to get a new rig (probably sooner rather than later now). Given that, my enthusiasm for poking the inside of my current box has completely gone out of the window.

    I'll just wait until I get that new machine before I play W&G. To be honest, I picked it up more on a whim than out of any great urgency to play them. The thing I'm really looking forward to is the next S&M season so I guess I have a deadline for my new purchace!

    Thanks again for all the help. I really do appreciate the effort. Sorry it didn't get resolved...

  • I had exactly the same problem (black boxes, missing graphics).
    I did the following:
    - I carefully updated all the video drivers (both using Windows Update and the graphics manufacturers website)
    - Updated DirectX to the latest version (from the microsoft site)

    But what really seemed to work is dropping the Graphics quality (From Wallace+Gromit Settings menu). Dropping it for 4 to 3 seemed to immediately solve all my problems (maybe not enough video ram?). Try seeing if dropping the graphics quality helps for you at all.

Add Comment