User Avatar Image

Why does Sam and Max lag and how should i fix it?

posted by Bertan1311 on - last edited - Viewed by 114 users

I have

Windows 7 Ultimate 64-bit
AMD Athlon 64 X2 Dual-Core Processor 5400+
GeForce 9800 GT 512MB
4GB RAM

All drivers updated and background programs turned off and Sam and Max still lags, it happened with episode 2 and it happened with episode 3... I play the game for 5 minutes and it starts to lag and it lags for about 30seconds-1minute and then it stops and the same cycle goes over and over... please help how should i fix it?:confused:

16 Comments - Linear Discussion: Classic Style
  • @Bertan1311 said: GPU 83C
    Temp1 52C
    Temp2 52C
    Temp3 -128C
    HD0 39
    Core 29C

    Is this it or did i mess something up



    Is this during play or outside of it? If its not during play you won't have an accurate picture of what's going on.

    Those temperatures seem a bit low for in use, especially the core temp (though the GPU temp seems high for idle as well).

    Also, I think the -128C is normal in SpeedFan, its just trying to grab a temp that's not there and probably returning the minimum value or something.

  • @Hatley said: Lower the graphics quality.



    This helped, but i don't get it... Is my pc so weak that it can't stand playing sam and max on higher resolution ?

  • @Bertan1311 said: This helped, but i don't get it... Is my pc so weak that it can't stand playing sam and max on higher resolution ?



    Your PC should easily be able to handle the game on max settings.

    Maybe you have some spyware? Or crazy overactive antivirus software?

  • I have a slightly better cpu than you and a quite a bit worse graphics card and I can play lag free at a fairly good resolution (1280x1024) and quality (9) so that shouldn't be it.

    Besides overheating you might want to check that all your drivers are up to date.

    Also, and someone else would likely know better than I, I think a lot of AMD boards tend to function better with ATI cards over Nvidia so you might check out your board as well.

  • I've also been getting overheating issues for "they stole max's brain". My laptop isn't great but plays at quality 5-6 smoothly usually and did so for the first two episodes for this season but this one starts lagging about 5 minutes after starting it. I diasbled spybot and that seems to help but even moving the quality down to 1 it will still eventually overheat lag for about a minute play normal for a mintute then lag again until I turn it off. I'm guessing it's a driver issue but I've got hybrid graphics so I'm a bit stuck as they don't get updated.

  • @Bertan1311 said:
    All drivers updated and background programs turned off and Sam and Max still lags, it happened with episode 2 and it happened with episode 3... I play the game for 5 minutes and it starts to lag and it lags for about 30seconds-1minute and then it stops and the same cycle goes over and over... please help how should i fix it?:confused:



    If the lagging is not related to where you are in the game, then it's not a performance issue. It can be overheating, or it can be a shortage of video memory (which it isn't, 512MB must be enough), or a software installation problem - game, video drivers, other drivers. Which ForceWare are you using? 257.21 got some bad rap across the web for being unstable. 197.45 worked fine on Win7 64-bit with my GTS250 (same GPU).

    Also, with your gear, you should be OK up to 1680x1050, level 9.

  • @Pantagruel's Friend said: If the lagging is not related to where you are in the game, then it's not a performance issue. It can be overheating, or it can be a shortage of video memory (which it isn't, 512MB must be enough), or a software installation problem - game, video drivers, other drivers. Which ForceWare are you using? 257.21 got some bad rap across the web for being unstable. 197.45 worked fine on Win7 64-bit with my GTS250 (same GPU).

    Also, with your gear, you should be OK up to 1680x1050, level 9.



    Yeah i know, but i have to play it at level 1 so it won't lag...
    P.S. My drivers are up to date

  • It's an overheating issue, i just upped the graphics to 9 and the resolution to maximum and the temperature went berserk... Anyway i also had this problem with Assassins Creed II and GTA IV Episodes from Liberty City... Any ideas how to fix this issue?

  • @Bertan1311 said: It's an overheating issue, i just upped the graphics to 9 and the resolution to maximum and the temperature went berserk... Anyway i also had this problem with Assassins Creed II and GTA IV Episodes from Liberty City... Any ideas how to fix this issue?



    A temporary fix would be pulling the side of your case off, that's what I do sometimes. :p

    Also make sure your tower isn't sitting on the floor, or in an enclosed area.

    If that fails, you may need to install some new fans, or possibly a water cooling system if the overheating is bad enough.

  • @Bertan1311 said: It's an overheating issue, i just upped the graphics to 9 and the resolution to maximum and the temperature went berserk... Anyway i also had this problem with Assassins Creed II and GTA IV Episodes from Liberty City... Any ideas how to fix this issue?



    How old is your VGA? If it's more than a few months, then it's possible that the heat sink collected enough dust to block the airflow. If you're experienced in computer assembly / disassembly, then it's quite easy to check (and clean it up), if you're not, then ask a friend who is.

Add Comment