User Avatar Image

Puzzle Agent Graphical Bug on Puzzle 2 with Snowmobile

posted by Depops on - last edited - Viewed by 3.8K users

I have both of these problems. ESC doesn't work and there's no automatic save after the first puzzle.

In addition, there is a problem with the second puzzle. The background of the puzzle is on top of the rest of the objects so I can't see what's happening.

07TfXl.jpg

DirectX has been updated. This problem occurs both in fullscreen and windowed. I don't know what else I could try.

276 Comments - Linear Discussion: Classic Style
  • Yeah, it's definitely something with the scene priorities, we just don't know why one particular card would draw things in the wrong order. Just won't make a whole lot of sense until we can see what's going on under the hood.

  • Some more info from me:

    I have a Windows 7 64-bit partition and a Ubuntu 10.04, on the same machine, which has an Nvidia GTX275 card. I've tested the game on both partitions.

    The first time I ran the game, it resulted in a complete and instant system crash on both partitions; an instant black screen with the monitor going in stand-by.

    The second time I ran the game on both partitions, it worked.

    The first puzzle is okay; but on Linux, and only on Linux, the second puzzle suffers from the z-order issue, where the piece of paper with the logs are clearly placed beneath the field where the logs are to be placed. Still, the logs are visible when you drag them around. (Trial and error to find them first).

  • I can drag the logs, but they are not visible unless I drag them above the map.

  • Nothing yet?
    Anyone tried any other older driver?

  • Same problem here.

    Linux 2.6.32-23-generic #37-Ubuntu
    wine 1.2-rc6
    nVidia Corporation G86 [GeForce 8400M GS]
    NVIDIA driver version 195.36.24

  • @Will said: Yeah, it's definitely something with the scene priorities, we just don't know why one particular card would draw things in the wrong order. Just won't make a whole lot of sense until we can see what's going on under the hood.

    Can we get some sort of update? I assume the card's been at the office for a couple days now...

  • We've figured out the root of the problem, but rather than being one system wide fix it means a bunch tiny little fixes. Basically the problem you saw in that second puzzle extends through the bulk of the game and they all need to be found and fixed individually. In short, it's going to take a little while :(

  • Good to hear you've found what's wrong. Unfortunate that the problem is so many little things instead of one big thing, but at least a fix is in sight. :)

  • @Will said: We've figured out the root of the problem, but rather than being one system wide fix it means a bunch tiny little fixes. Basically the problem you saw in that second puzzle extends through the bulk of the game and they all need to be found and fixed individually. In short, it's going to take a little while :(

    Well, I just downloaded the game and was all happy and gay about starting to play, but then I hit this bug and then ow... Well, I don't mind waiting, but how do you guys usually notify when these bugs are fixed? Will you send an update on this thread when the new version is ready for download?

    Cheers!

  • @Will said: We've figured out the root of the problem, but rather than being one system wide fix it means a bunch tiny little fixes. Basically the problem you saw in that second puzzle extends through the bulk of the game and they all need to be found and fixed individually. In short, it's going to take a little while :(


    Glad to hear that first part of it. Less so the second. But I will let you know I trust you guys enough that I bought the game full well knowing I would encounter this problem.

Add Comment