User Avatar Image

Puzzle Agent (Windows 7/64x): Could Not Initialize Direct3D

posted by hushed on - last edited - Viewed by 650 users

This just popped up as soon as I click "Launch Game" - it becomes totally unresponsive & I need to kill the entire process via task manager.

I removed and reinstalled the most recent display driver I could find, and I used the DX websetup to check out my DX11.

Here's my dxdiag all zipped up.

The card is an ATI HD 5850, but that should be in the dxdiag anyway. Thanks in advance if you see something I missed.

10 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator

    Try disabling your second display.

  • that worked - thank you.

    any specific reason this happens, out of curiosity

  • User Avatar Image
    DjNDB Moderator

    @hushed said: that worked - thank you.

    any specific reason this happens, out of curiosity

    You're welcome. I don't really know why it happens. It's just something that happened in S&M S3 too.

  • Hmm, that's *still* happening? Ok, I'll reopen the bug. Thanks for the heads up and sorry about that!

  • @Will said: Hmm, that's *still* happening? Ok, I'll reopen the bug. Thanks for the heads up and sorry about that!


    Yes, it unfortunately is... :(

  • I am also getting that error, followed by another: "Unfortunately, this error cannot be recovered." :(

  • User Avatar Image
    DjNDB Moderator

    @xbskid said: I am also getting that error, followed by another: "Unfortunately, this error cannot be recovered." :(

    Have you made sure your display color depth is set to 32 bit?
    Did you disable your second display, if applicable?

  • @DjNDB said: Have you made sure your display color depth is set to 32 bit?
    Did you disable your second display, if applicable?

    Yes, my color depth is 32bit, and no, I did not disable my second display. I think it's a bit silly to have to rearrange my icons and disable a monitor in order to play Puzzle Agent when I don't have to do that for Sam & Max Season 3. The game does seem to run just fine if I enable compatibility mode for Vista (SP2)--even includes the text labels on the Yes/No quit menu buttons that wouldn't appear for me under Windows 7 x86.

  • Workaround that worked for me (since I use Win7 x64 + ATi and I refuse to disable my second screen, that's just plain dumb) - for Sam&Max S03E03, that is.

    1. Set your previous episode (or maybe it would work with another TellTale game even) to run in windowed mode.
    2. Copy file prefs.prop from the previous game (e.g. C:\Users\username\Documents\Telltale Games\The Tomb of Sammun-Mak) to the new game (in my case, C:\Users\username\Documents\Telltale Games\They Stole Maxs Brain)

  • @analytik said: Workaround that worked for me (since I use Win7 x64 + ATi and I refuse to disable my second screen, that's just plain dumb) - for Sam&Max S03E03, that is.

    I too have an ATI card, and I also refuse to disable my second display. Have you tried just setting the compatibility mode to Vista SP2?

Add Comment