User Avatar Image

Can't watch the videos on the homepage

posted by Avistew on - last edited - Viewed by 475 users

The videos on the homepage started automatically, so I installed flashblock to prevent that. Now I have to click on them first, and only then do they play.

Which is nice, and it worked, but for some reason not anymore. I went to watch the Puzzle Agent trailer again, but when I clicked on the little flash icon (which for any other video allows me to play it) I ended up on the Puzzle Agent page.
Very weird.

So I can't watch the videos anymore. I'd have to remove flashblock, but I'm not willing to get the automatic videos, I'd rater take no vid at all.

Just throwing it out there.

13 Comments - Linear Discussion: Classic Style
  • @DjNDB said: Instead of flashblock you can use a greasemonkey script to just disable autoplay.
    I attached a simple one that disables autoplay for the main page.

    I tested it on Firefox with the greasemonkey extension, but it might work on other Browsers which support greasemonkey scripts too.

    In order to install the script, remove the .txt extension from the file and drag it onto the firefox window.

    Thanks! That's very nice of you.

    EDIT: Worked perfectly, thanks!

    RE-EDIT: I still have the same problem btw. The video doesn't start automatically, but if I click on "play" on it, it doesn't play the video, it goes to the Puzzle Agent website.
    Clicking on the "play" button on the bottom left works, though.

  • User Avatar Image
    DjNDB Moderator

    @Avistew said:
    RE-EDIT: I still have the same problem btw. The video doesn't start automatically, but if I click on "play" on it, it doesn't play the video, it goes to the Puzzle Agent website.
    Clicking on the "play" button on the bottom left works, though.

    It is probably intentional behavior that you get to the puzzle agent website by clicking the video.

  • @Avistew said: You might accidentally have made an exception for it? Check the settings, maybe.

    All this time I've been trying to find the settings by right clicking everywhere! I just found it in my main toolbar, in tools, in add-ons. Once there it was easy to see you were right. I don't know how, but I had made exceptions for Telltale and MySpace. Does anyone know how I might of done it, so I can avoid doing it again?

    EDIT: Out of pure curiousity, I tried clicking the trailer for Puzzle Agent. I now have the same problem as Avistew, it takes me straight to the main page for Puzzle Agent. Quite weird.

    EDIT EDIT: Actually, it happens when I try to watch any of the video's on the homepage. Even weirder.

  • User Avatar Image
    DjNDB Moderator

    @jeeno0142 said:
    EDIT: Out of pure curiousity, I tried clicking the trailer for Puzzle Agent. I now have the same problem as Avistew, it takes me straight to the main page for Puzzle Agent. Quite weird.

    EDIT EDIT: Actually, it happens when I try to watch any of the video's on the homepage. Even weirder.

    There's a DIV linking to the Puzzle Agent page covering most of the video area.
    Try clicking at the bottom of the area instead.

  • i also have flashblock installed and the video just plays fine when i click the flashblock button and the play button. i can click anywhere in the video window and it plays just fine.

    do you have any other addons installed that could cause this behaviour?

  • Confirmed, need to click at the bottom to watch the video, whether with flashblock or not, clicking on the vid itself brings you to the website.

    I figured it wasn't a bug, DjNDB, but I thought whoever did it might not realise it prevented people from watching the videos at all if they have autostart disabled.
    I'm not sure everyone will think to click at the bottom. While with the script I can see the "play" button and therefore clicking down there makes sense, with flashblock I only see the flash icon at the middle and wouldn't have though to click at the bottom instead.

  • @DjNDB said: There's a DIV linking to the Puzzle Agent page covering most of the video area.
    Try clicking at the bottom of the area instead.

    What do you know! That works for me too! Thanks for the tip, I can remember it for in the future now.

  • If you use Flashblock, watch for the "f" icon to change to the "play" triangle icon when you mouse over the video. If you click on the video while the "f" icon is still visible, you'll be redirected to the Puzzle Agent page. When the icon changes to "play" near the bottom of the video area, clicking will start the video.

    Right-clicking on a Flash object while the "play" triangle icon appears will give you the option to add the site to the Flashblock exception list.

  • I never noticed that before, but it seems really obvious now! Learn something new everyday...

  • @DjNDB said: Instead of flashblock you can use a greasemonkey script to just disable autoplay.
    I attached a simple one that disables autoplay for the main page.

    I tested it on Firefox with the greasemonkey extension, but it might work on other Browsers which support greasemonkey scripts too.

    In order to install the script, remove the .txt extension from the file and drag it onto the firefox window.

    You are officially my favorite person in the world right now. I can finally actually go to the Telltale website again. I have avoided going to this site for weeks because I hate that autoplaying video SO MUCH!!!

    As an additional note, even though blocking the autoplay was pretty easy now that I have this script, I think it is horrible that there is not a built in button on the main page allowing anyone on any browser to disable autoplay.

Add Comment