User Avatar Image

Sam and Max slow/choppy video

posted by luigi6699 on - last edited - Viewed by 597 users

I bought Sam and Max 30x on Steam and have been playing the games on my Macbook pro. They've worked very well, until I started with episode 304. The introduction (before the theme song) runs OK; not really smooth unless I turn down the resolution to 800x600, but I've had that before with the earlier games. Once the cutscene starts inside Stinky's though, it's VERY choppy. Like 1 frame every 2 seconds kind of choppy. Audio is mostly unaffected. This persists into the gameplay; even the mouse movement is so slow and delayed as to be unusable!

I turned all the video settings down to their minimums, and didn't see any improvement. I restarted my computer, and now I can't even launch the game! The game menu never appears, I just get nasty corrupted graphics. If I hit shift-tab to see the steam community options, that screen displays fine. But I cannot get to the main menu at all. If I quit with Apple+Q, I get a very brief flash of the menu as it's quitting.

I have tried running 302 since then, and it runs fine. Only 304 has this problem. It was unplayable at first, and now it's TRULY unplayable!

Any advice? This seems like a pretty major glitch that someone else would have noticed by now!

20 Comments - Linear Discussion: Classic Style
  • Well technically its sam and max 301 not 204, but either way, I reinstalled it and now it says my mac doesn't support that game. So now I definitely can't play it.

  • ... where did I get 204 from?

    Anyway, what is throwing the "unsupported" error message, Steam?

    Also are all of your mac updates up to date?

  • It might be steam, and yeah they should be.

  • Ok I just got the new mac graphics update and its back to screwing up like it was before. I've done everything that everyone's suggested.

  • Hi qing - nice to know someone else is having this problem!

    I got all excited because of the Mac graphics update. I installed it, uninstalled SM304 and reinstalled it... stil the same corruption issue. I wonder if it might be something in the settings, like the game is trying to use a resolution that my laptop's monitor doesn't support, something like that.

    I tried deleting the com.telltalegames.SamMax304.plist file, but no luck. Judging from the file modification times, Steam deletes and recreates that when you uninstall and reinstall anyway.

    What REALLY gets my goat is that this DID work at one point. I could get into the game, though it was terribly choppy. So I know this isn't a hardware issue... the only thing that changed was I set the graphics to their lowest possible levels and restarted the game. Can I use command line switches or anything to manually set windowed mode, or set specific graphics modes?

  • Quick update: I just installed it on my Windows 7 partition (bootcamp), and in Windows the game plays fine. So this is definitely not a hardware issue.

  • Yeah I did the same thing. I lowered the settings all the way. It worked until I quit the game and tried to open it again. So I think we are having the same problem.

  • Well, I've never tried this before so let's see what happens. I've attached my plist with everything set to the lowest possible safe values. Try replacing yours with this one.

    Note: due to the wonky forum rules, I had to rename it to .txt. Just change the .txt back to .plist

  • So, I finally bucked and bought the full series from TellTale directly. (I was having this issue with the Steam version). Lo and behold, every SnM game works flawlessly from TellTale.

    So at least we know this is Steam's fault. Unfortunately, I never did find a way to make the game work through steam. On the plus side, I got all the SnM games! yeahhhh!

Add Comment