User Avatar Image

Time to Fix Puzzle Agent

posted by Elron on - last edited - Viewed by 251 users

Dear Telltale:

It has been over five months since people purchased Puzzle Agent only to discover that it doesn't work on newer nVidia graphics cards. It is now time to release the fix for this. Even the mods in the forums have stopped responding because there is nothing else they can say to appease the poor consumers who were cheated out of a game because of this. I also see you are releasing a Wii version of Puzzle Agent. It's very impressive that you have time to port the game to another platform, but still can't find the time to fix the game you've already release to the PC. If you don't stand behind your products, why should we? As a developer myself, I understand the difficulty in fixing bugs at times, but really, over five months? Just fix it already.

13 Comments - Linear Discussion: Classic Style
  • @joehonkie said: No, this is like yelling at a merchant who has sold you a product in good faith and failed to deliver the working product. No amount of workload (which is part of their normal business) makes this acceptable.



    Thank you, Joe. For ANY critical bug fix by ANY company, over five months is TOO LONG when the game is unplayable.

  • Just got this game with the back to the future preorder. It crashes on start for me with DirectX errors. I have fully updated directx and my video card. Yay... =/ Time to keep surfing the forums.

  • If I understand, isn't the bug with nvidia? The game works fine for me (GTX280) on latest drivers, it's a driver issue on how it treats those newer cards.

  • Could someone link me to this support thread where people are talking about this, I honestly dont see it.

  • @Ash735 said: If I understand, isn't the bug with nvidia? The game works fine for me (GTX280) on latest drivers, it's a driver issue on how it treats those newer cards.



    I guarantee you have 32bit operating system. It only affects GTX 270/280 nVidia drivers on a 64bit operating system.

    And I just tried the new drivers release 10/25 and it's still broken. Telltale has admitted they know how to fix it, but would need to fix all the puzzles, so I guess that's as far as they got.

    I'm glad it's working for you. Enjoy it.

  • @Elron said: I guarantee you have 32bit operating system.



    Windows 7 Home Premium 64-bit. You now owe me money! :D

    Well, I've finished the game, so either the bug is really small and I didn't notice it, or, I just didn't get this bug.

  • @Ash735 said: Windows 7 Home Premium 64-bit. You now owe me money! :D

    Well, I've finished the game, so either the bug is really small and I didn't notice it, or, I just didn't get this bug.



    EDIT: I'm sorry, I made a mistake earlier. The problem exists on the 4xx series of graphics cards, NOT the 2xx series. That's why you are able to play without issue.

    The bug IS a big one. On the second puzzle, the z-order of the overlayed screens for the log-moving puzzle is wrong. The grid is completely empty, and the person and logs are UNDER the grid screen and cannot be reached. Actually, you can see the upper left corner of a log and can grab it with the mouse, but as soon as you drop it, it hides under the grid screen again. The puzzle cannot be solved and the story cannot move forward.

  • For laughs for people: it's still not on par with lighthouse for mac ;) That game never worked, even after they patched it, it didn't work ;) Crashed during the intro scene due to a missing movie file that never shipped on the CDs...

  • @Elron said: I guarantee you have 32bit operating system. It only affects GTX 270/280 nVidia drivers on a 64bit operating system.

    And I just tried the new drivers release 10/25 and it's still broken. Telltale has admitted they know how to fix it, but would need to fix all the puzzles, so I guess that's as far as they got.

    I'm glad it's working for you. Enjoy it.



    Also affects 4xx series.

    Still broken for me. 2nd puzzle. Win7 64 GTX 470. Fix plz. I bought your other stuff, but I regret buying this. I can not purchase any more telltale products while you let a known issue continue. More and more people will be getting fermi cards, more people will be getting 64-bit operating systems. There is no reason this game should be unplayable for these customers.

  • There is a new installer in the MyTelltale page. It appears to be 50MB smaller than the original installer.

    It's being discussed here.
    http://www.telltalegames.com/forums/showthread.php?p=414106#post414106

    The Steam version has also been fixed.

Add Comment