User Avatar Image

Telltale's site won't load for me.

posted by RAnthonyMahan on - last edited - Viewed by 900 users

Whenever I try coming here it gives me an error message (I had to post this from my iPhone). The site's clearly not down. I tried restarting my computer and waiting a while, but that didn't help.

Any ideas? With Poker Night and BttF on the way, my computer needs to be able to access this site soon.

15 Comments - Linear Discussion: Classic Style
  • Same issue as Anhony. Have to use my Android. I thought it was my network. IP pings time out. It came.back for a bit and is not connecting again now. Had to take my phone off WiFi to access the site.

  • User Avatar Image
    DjNDB Moderator

    It seems to be some weird network issue, occuring only in some networks...
    In my case DNS seems to be a problem.

    It doesn't work with my DSL connection:
    $ nslookup

    ** server can't find NXDOMAIN

    It does however if i use a VPN, e.g. hotspot shield.

    $ nslookup

    Non-authoritative answer: canonical name =

    As you can see i even ask the same DNS server (, google DNS) both times and get different answers.
    I have no idea why this happens, since both are recursive DNS requests to the same server. That means, does the iterative DNS resolving and should give the same answer, seemingly depending on my route to the DNS.

    For now i'll work around it by adding
    to my hosts file, until it's fixed.

  • This site breaks on me like every day...

  • I was having this issue yesterday, but it seems to have resolved itself for me.

  • User Avatar Image
    DjNDB Moderator

    All of TTGs DNS Servers for seem to be fine, btw. Who knows what's going on along the way.

  • My Internet was out all week, so I experienced no issues. So there. If you're still mopey, well a fie on you! Also, this song will cheer anyone ever up.

  • Well, I got the same problem yesterday. I kept trying to get the webpage to load, but I always got an error message. It seems the problem may have been resolved with the servers, though I'm not sure how long it will last.

  • I've been having this problem all day, tried clearing the cache, resetting my network connection, I even tried using IE instead of Firefox but I kept getting the same "cannot find server" error. It was happening yesterday as well, but only on and off. Ah well, seems to be fixed now.

  • I had the same problem a couple of days ago. Telltale's site wouldn't load no matter what I did on my PC.

    But then I actually managed to get it working by going into my router's config and switching from British Telecom's DNS server to Google's.

    Then this morning it was down using the Google DNS as well. But now it's up again. o_O

    Do you guys have some sort of rouge DNS record flying around or something?

  • User Avatar Image
    DjNDB Moderator

    Everything seems to be fine here since a couple of hours ago.

Add Comment