User Avatar Image

Sam & Max DVD-Vista-System Registry Error

posted by DJTuffPuppy on - last edited - Viewed by 652 users

I don't get very far. I pop in the DVD disc and it autoplays. I am greeted with the message "Error accessing system registry". I click "ok" when really it's not and I get "Unexpected error; quitting".

I meet the system requirements no problem. Might have something to do with me using either 1) a laptop or 2) Windows Vista. Anybody got any ideas?

11 Comments - Linear Discussion: Classic Style
  • Solved!

    I turned off User Account Control on Vista and it ran no problem. I just get Vista warning me about the great danger I am in almost every single time I start my computer, but that is the price I pay to fill the Sam and Max shaped hole in my life.

  • Thanks for posting what worked for you. :D

    Vista has so many little quirks (all stuff it's supposedly doing to protect you!) that it can be really hard for us to make suggestions on these types of issues. We're mainly still using XP in the studio -- only a couple of people have Vista -- which can make it hard to do the kind of tinkering needed to figure this stuff out.

  • Vista is also apparently a permissions nazi.

    I'm generally not a huge fan of the Mac vs PC ads on TV, but this one is kind of true, and depressing.

  • Yeah, same issue. Vista's supposed to automatically detect if an application requires admin rights, but fails to do so for the autorun.exe on the S&M DVD.
    Just browse to the DVD Root, and select the compatibility settings for the autorun.exe to always run as administrator.

    Telltale Team: this could have been avoided if the autorun.exe had a manifest stating the requirement for admin rights. Maybe helpful in the future.

    Example manifest:
    <?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?>
    <assembly xmlns=\"urn:schemas-microsoft-com:asm.v1\" manifestVersion=\"1.0\">
    <assemblyIdentity version=\"1.0.0.0\"
    processorArchitecture=\"X86\"
    name=\"ExeName\"
    type=\"win32\"/>
    <description>elevate execution level</description>
    <trustInfo xmlns=\"urn:schemas-microsoft-com:asm.v2\">
    <security>
    <requestedPrivileges>
    <requestedExecutionLevel level=\"requireAdministrator\" uiAccess=\"false\"/>
    </requestedPrivileges>
    </security>
    </trustInfo>
    </assembly>

    This manifest can of course be in the exe itself, or just in the same folder, named autorun.exe.manifest.


    By the way, I love the commentary for the cutscenes :)

  • @Jake said:
    I'm generally not a huge fan of the Mac vs PC ads on TV, but this one is kind of true, and depressing.



    the UK versions were better starring Mitchell and Webb (2 british comedians)

  • I think a more pertinent question is why does an autorun need administrative privileges at all?

  • [quote=Jake;38027]Vista is also apparently a permissions nazi.

    I'm generally not a huge fan of the Mac vs PC ads on TV, but this one is kind of true, and depressing.[/quote]

    That's the biggest downside of Vista. Logging into my account takes about two seconds, but I have to wait another thirty seconds where I can't open anything because it's waiting for a Logitech Updater permission box to appear.

    (...that probably doesn't make any sense until you see it)
    I've now fixed this - turns out I just needed to update my Logitech software.

  • i also use vista and dont get so many warnings but maybe i dont use the sort of programs that require them

    its faster than xp by far i used my xp pc the other day and it seemed so slow

  • [quote=patters;38121]i also use vista and dont get so many warnings but maybe i dont use the sort of programs that require them

    its faster than xp by far i used my xp pc the other day and it seemed so slow[/quote]

    I get warnings when I try to move a file!

    But apart from that, Vista is great. :)

  • A little thing about VISTA warnings after UAC have been disabled - you can get rid of them by disabling Windows Defender. Has to be done in Services to go away all together.

Add Comment