User Avatar Image

Can't activate English language!!! :(

posted by SonataFanatica on - last edited - Viewed by 2.6K users

Hey guys.

Okay, just downloaded the game. I specified it as "English" in the drop down menu, of course. The installer itself IS English, too. But as soon as I start the launcher, everything is in German!! :mad: All the labels in the menus are in German and so are the lines of dialogue one can choose! (Of course the spoken language is still English though.)

How on EARTH do I get to play the game in FULL English??
Because I really don't want to click German lines of dialogue when English is the spoken language (which I absolutely prefer, in the first place)!!!

:mad: :(

42 Comments - Linear Discussion: Classic Style
  • @skeez said: I actually wanna have it in german and all I'm getting is german texts and english audio.. I've already set my language settings to german. Doesn't seem to help apart from the german subtitles.. I'm on a mac, 10.6.5.

    If you want German audio, I think you should download a different file.

  • @Javi-Wan Kenobi said: If you want German audio, I think you should download a different file.

    Yeh like selecting "german" in the downloads options? ;) It doesn't work.

  • @skeez said: Yeh like selecting "german" in the downloads options? ;) It doesn't work.

    What do you mean? The link doesn't work? Or it's still english audio after downloading the supposed german audio file?

  • Exactly, it's still english though it's supposed to be german.

  • I'm from Germany but I want (and downloaded) the all English version.
    But it doesn't work here either. Please fix this horrible travesty.

  • I have selected "french" before download. The menu and subtitles are in french it's perfect but voices in german, i would like in english :/

  • To disable the german interface texts (or subtitles) on a german Windows, simply rename the /Episode1/Pack/Localized/german folder. Then the game won't find the texts and display the english ones instead.

    Same applies for french; and you don't need to change anything on your machine.

    But seriously, this should be a setting of the game.. So please telltalegames, add some setting for that..

  • Unfortunately in-game texts are still german after renaming the localized folder :[

    Support++
    Is there an other workaround to skip auto language detection?

    Edit:
    Found this in an other thread:
    Set this Key in the Registry
    ------

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telltale Games\BackToTheFuture101.exe]

    "Language"="english"

    ------

  • User Avatar Image
    DjNDB Moderator

    @poke said: To disable the german interface texts (or subtitles) on a german Windows, simply rename the /Episode1/Pack/Localized/german folder. Then the game won't find the texts and display the english ones instead.

    That didn't work for me.


    Here's a solution that doesn't require a restart. You just need to add a registry key. I only tested it on Windows 7 64-Bit and Windows XP 32-Bit yet. It should work with any version though, if you correct the Registry path.

    The Win7 64-Bit registry settings will probably work with Win7 32-Bit as well. If someone tests that, please let me know, so i can edit it here.

    Windows 7 64 bit:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Telltale Games\BackToTheFuture101.exe]
    \"Language\"=\"english\"

    Windows XP 32 bit:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Telltale Games\BackToTheFuture101.exe]
    \"Language\"=\"english\"

    For convenience i attached a zip containing .reg files for both Windows Versions for adding and removing the Language key. Look at the end of the File name to find the right one for your Windows Version. Just double click the appropriate .reg file and confirm the changes.

    Add the Language Key:
    BTTF-add_English_Language-Win7_64Bit.reg
    BTTF-add_English_Language-WinXP_32Bit.reg

    Remove the Language Key:

    BTTF-remove_English_Language-Win7_64Bit.reg
    BTTF-remove_English_Language-WinXP_32Bit.reg

  • @DjNDB said: Here's a solution that doesn't require a restart. You just need to add a registry key. I only tested it on Windows 7 64-Bit and Windows XP 32-Bit yet. It should work with any version though, if you correct the Registry path.

    Great, that did it for me. Couldn't get the game to run with english text with the other workarounds, but the Win 7 64 reg key worked like a charm. Thanks a lot.
    Unfortunately I already finished the game yesterday, because I couldn't wait for a solution, but now I can play it again like TTG intended it to be played.

Add Comment