User Avatar Image

BTTF - Limiting Framerate

posted by AlteredTomorrow on - last edited - Viewed by 285 users

I need to know if there's a way in-game to turn on vertical sync, or more importantly, use some kind of console command to limit the framerate.

The game runs spectacularly on my computer, but after a short time it overheats and crashes so I need to find some way to limit the framerate.

Thanks!

20 Comments - Linear Discussion: Classic Style
  • Depends. If you're using Windows and a multicore processor and it's the CPU that's overheating you can always alt+tab out of the game, hit CTRL + ALT + DEL and start the task manager. Locate the game on the process list, right-click on it and choose 'Set Affinity'. You'll get a list of the cores assigned to the task and you can disable all but one and see how that goes. You'll have to do this every time you run the game however.

    If it's a GPU overheating issue you can set the resolution and/or detail down to try and reduce the demand.

  • @ForumPoster said: Depends. If you're using Windows and a multicore processor and it's the CPU that's overheating you can always alt+tab out of the game, hit CTRL + ALT + DEL and start the task manager. Locate the game on the process list, right-click on it and choose 'Set Affinity'. You'll get a list of the cores assigned to the task and you can disable all but one and see how that goes. You'll have to do this every time you run the game however.

    If it's a GPU overheating issue you can set the resolution and/or detail down to try and reduce the demand.



    Thanks for your post.

    I'm almost positive it's a GPU overheat. I'd rather not reduce the quality as some way to reduce the framerate would produce the desired effect without sacrificing quality, but it may come to that.

  • Use real-time monitoring programs like GPU-Z and CPU-Z, have them log temps in the background and run the game till it crashes.

    Then check your CPU and GPU temps at the crash time, as well as checking Event Viewer.

    If you want to try Vsync, you can enable it via your graphics card driver.

  • User Avatar Image
    DjNDB Moderator

    Once you identified what overheats, you could as well just improve your cooling solution.

  • @DjNDB said: Once you identified what overheats, you could as well just improve your cooling solution.



    Right, I'm playing on a laptop and there's not much I can do to improve the cooling besides what I've already done such as elevate it and clean it. It just generally overheats on games with uncapped and/or high-end capped framerates.

    Forcing V-sync through my video card options seems to have fixed the problem for now. Though 60 frames is still too much in some cases.

  • Google for fps limiter 0.2

    run FPS_Limiter_GUI (requires java)

    Search executable and find the BackToTheFuture101.exe in your install directory and put in about 32 on maximum fps, then create bat. Run the bat file that it creates in the fps limiter folder for now on to play the game. I did this with S&M TDP because the frame rate in that game is too all over the place. Fortunately Telltale seemed to do a very good job on getting BttF optimized.

    edit: and keep it on D3D9

  • @hatless sam said: Google for fps limiter 0.2

    run FPS_Limiter_GUI (requires java)

    Search executable and find the BackToTheFuture101.exe in your install directory and put in about 32 on maximum fps, then create bat. Run the bat file that it creates in the fps limiter folder for now on to play the game. I did this with S&M TDP because the frame rate in that game is too all over the place. Fortunately Telltale seemed to do a very good job on getting BttF optimized.

    edit: and keep it on D3D9



    Thanks for your post and for including instructions.

    I tried what you said and I get an error when running the bat, could it be because I'm running the game on Steam?

    Also enabling v-sync didn't fix the problem, but it allows a little more time before overheating occurs.

  • Normally Steam doesn't allow any changes or proxies for it's game exe, but FPS Limiter does work with Steam games.

    Anyway, you really need to sort out this overheating, though, it shouldn't be happening with any game and especially not when you're forcing VSync.

    In the meantime, if you want to lower the frame-rate try enabling VSync, AA and AF through your video card driver.

    You could also try other video card driver versions, as that may help your temps.

  • @Kleetus said: Normally Steam doesn't allow any changes or proxies for it's game exe, but FPS Limiter does work with Steam games.

    Anyway, you really need to sort out this overheating, though, it shouldn't be happening with any game and especially not when you're forcing VSync.

    In the meantime, if you want to lower the frame-rate try enabling VSync, AA and AF through your video card driver.

    You could also try other video card driver versions, as that may help your temps.



    How do you suggest I sort it out? I'm open to any suggestions.

    I have the latest drivers which give me the best heat management that I've experienced so far with the drivers I've had throughout time.

    I have my laptop elevated and I keep it clean as I mentioned before.

  • User Avatar Image
    DjNDB Moderator

    @Kleetus said: In the meantime, if you want to lower the frame-rate try enabling VSync, AA and AF through your video card driver.



    That would increase the load on the graphics chip of course, and in turn produce more heat in the GPU.

    I would start with measuring the temperatues as kleetus said. Once you definitely know whether it's the GPU or CPU measures can be taken.

    Either way, you could try reducing it's speed and especially voltage.

Add Comment