User Avatar Image

Launcher problem

posted by silence42 on - last edited - Viewed by 1.2K users

when I double click on the icon and the launcher comes up all i can see is the background picture with marty and the deloran...no episode names or button to start the game.

56 Comments - Linear Discussion: Classic Style
  • Is there a similar solution for those running on a Mac? I'm having the same problem; launcher shows up with just the picture of Marty, no episode name or button. Running on a home network.

  • User Avatar Image
    divisionten Moderator

    @stupei said: Is there a similar solution for those running on a Mac? I'm having the same problem; launcher shows up with just the picture of Marty, no episode name or button. Running on a home network.

    Does your home network have a firewall?

    (On a different note, awesome username. Persona 3 FTW)

  • That's the weirdness. No firewall up, yet my MBP has absolutely no problem verifying the DRM using the same network as my iMac, which can't get past the launcher. I've tried over my wireless and over ethernet on the iMac, and both are no go.

    It seems like something in the launcher disagrees with something specific to my iMac, but I have no idea what it is. Both are running 10.6.6. As I said, both are on the same network and I don't have a firewall up.

    I mean I guess I could just play it on the MBP, but I'd rather enjoy it on the bigger monitor.

    Right now, for me the launcher looks like this: https://img.skitch.com/20110330-pwnqcd6udnb1m2n12eyiayxp1g.jpg

    (And hey, thanks. Always cool when someone knows the reference. Persona 3 is truly one of the best.)

  • I tried this one, but no "BINGO" for me ... :(
    I have emailed the support desk and am awaiting a response.
    BTW I didn't find the values mentioned within "Current_User" I found them under "Local_Machine"





    1. Run regedit.exe
    - If you've never ever done this before - STOP NOW. For advanced users only :p

    2. Find HKEY_CURRENT_USER\Software\Telltale Games\Launcher

    3. Delete the entries "id", "login", and "password"

    4. Close regedit

    5. Run the BTTF Launcher again, and enter your user name and password again

  • I'm having a similar problem to this. This happened each time I installed a new BttF episode. I'm playing from my own computer at home. When the launcher was non responsive with the background showing, the ctrl shift trick worked.

    But for the last two episodes the launcher didn't show any background picture and the ctrl shift trick didn't work. However, in episode 4 the launcher suddenly worked a day after I installed it (I don't know what happened).

    As I've just installed ep 5 the same could happen here but I was just curious to see what was causing this.

  • Well so far I can't launch the game. Anyone have any other tips to get it to work?

  • This sounds to me like a network connectivity issue, especially since you say for 104 it didn't work at first, but then a day later it did. If you have any firewalls in place, shutting them off temporarily might help.

    Otherwise, all I can can really recommend is to keep trying. Open the launcher, give it a minute or two, and it nothing appears, close it and try again. On the bright side, if you can just get it to work once so you can log in, you shouldn't have to worry about it ever again.

  • I tried turning off the firewall but that didn't work. I guess I'll just keep trying.

    Thanks for the info anyway :)

  • Is there any way to actually skip the launcher so I could just play the game?

    I'm guessing the answer is no or all these problems would be much easier to solve... but I thought it'd be worth to ask.

Add Comment