User Avatar Image

Puzzle Agent 2 won't start Mac

posted by supersean579 on - last edited - Viewed by 280 users

I'm trying to play puzzle agent 2. I get the opening screen but I can't select anything. There is no play button. Here is a screenshot. Please help.

6 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Blitzci Telltale Staff

    Can you tell me which operating system version you have? This looks like a problem we saw in testing, but we thought we fixed it for all versions. We'll see if we can reproduce it.

  • I'm running OS X 10.6.8

    Thanks for your help.

  • User Avatar Image
    Blitzci Telltale Staff

    That's strange. We've tested the Mac build on a 10.6.8 and didn't encounter this problem on the version we shipped. Can you try redownloading it?

    It seems like the game is confused about whether you're logged in. If you ARE logged in, you should be able to see your Telltale ID name in the top-right corner of that window, but in that screenshot it's not visible. If you're not logged in, you shouldn't see that window at all. Instead, you should see a login screen. Redownloading might fix that problem.

    Otherwise, you might try deleting (or moving) the contents of this folder:

    Library \ Application Support \ Telltale Games \ Puzzle Agent 2

    That folder should have some files that keep track of whether or not you're logged in. Deleting them might iron out the game's confusion.

  • Hi,

    I've been having the same problem since I bought the game the day it came out. I've tried what you say here but had no luck. I first tried on Snow Leopard, then updated to Lion to get the same result.

    I can confirm the game starts just fine on other macs, but not on mine.

    Also, emailing Telltale support is useless as I've already sent them 3 emails and never received any answer.

    Thanks in advance.

  • @tmdchi said: Hi,

    I've been having the same problem since I bought the game the day it came out. I've tried what you say here but had no luck. I first tried on Snow Leopard, then updated to Lion to get the same result.

    I can confirm the game starts just fine on other macs, but not on mine.

    Also, emailing Telltale support is useless as I've already sent them 3 emails and never received any answer.

    Thanks in advance.

    Do you have the support ticket number?

  • I am having a similar problem, however am not able to get past the start up page. The cursor won't move from the corner and I cannot select or continue and am forced to quit the game: lHqJV.png

    I am running Mac OS X 10.5.8

    I have tried restarting the game, deleting and re-downloading it and restarting the computer after each process. Same problem every time I start.

Add Comment